summaryrefslogtreecommitdiff
path: root/sys-cluster/crmsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 16:21:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 16:21:19 +0000
commit413ca4e6c2089d8b5e0844c26cf5671209226b93 (patch)
tree843d96aa9dd26a13748de845900cf158a2a2ad53 /sys-cluster/crmsh
parent9263a8dda30106335f556e7f5936f5607db6f92c (diff)
gentoo auto-resync : 08:11:2023 - 16:21:18
Diffstat (limited to 'sys-cluster/crmsh')
-rw-r--r--sys-cluster/crmsh/Manifest2
-rw-r--r--sys-cluster/crmsh/crmsh-4.5.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
index f2a9da8ff4df..351ae25f7901 100644
--- a/sys-cluster/crmsh/Manifest
+++ b/sys-cluster/crmsh/Manifest
@@ -1,3 +1,5 @@
DIST crmsh-4.2.1.tar.gz 1058921 BLAKE2B 84d1f8685e792d9f453b2d185ccda4e8c2c9566becd85ed8308c014bd18e1479f601f3e89e4a1c3464c0d5bb797d7ddf9ddff479cd8c4c0d2998fd528f8ecbd2 SHA512 df0945f1b977993a0aca89af7c9030bc798aac4397a9d448d47bf68331e8aec83fa6155f2897f3c84573bcdb20fa384a1489b4f1d69fd1a831ece2fdb2b5b321
+DIST crmsh-4.5.0.tar.gz 1210069 BLAKE2B 078baa9b0c0cadb19f041ad48ffb9588f8c1eff634f115bc9ddd46be7e5c2555a1c493332f6cf01f08c683d39687f0e1e71854f6c56c3e1f30fe712ecb65c772 SHA512 f76e41ffc2fc9ac728350f551e658852015c4fd430f69f7a6d0882c265f65ae545f2ef1102bd20349790e46a0a3ec8222947eee6aef73d0afcaf13eb2b3c56a3
EBUILD crmsh-4.2.1-r3.ebuild 941 BLAKE2B 3545edf98389e0b37e28bacbbc800c2f45eceebb402b0edd75ee13fbb7264dfa7c09b657a4af7c58d7322c601ace41a9ff560162092a9fea77958db47acdb837 SHA512 872bc6d08e684f57f59276c693c4f00153ce04f4f66f5b4011111334cc8bc19c91c71469c390a69ebb7dabb8e55724debc0d383f0bed3ad1efba74dd2db777c8
+EBUILD crmsh-4.5.0.ebuild 937 BLAKE2B be9d9cd557a3770ec86774b23c4ddc2ce1bdd3aa2bee8983d12778c8765eeae9a5598a7f924a1c70e7a910a078561190b7e2ca8a5cddbb503ba00280890382ab SHA512 d30832abd876c9ad49537addc11ec77173c97a2301074566c4d9599a95bcdbcbdf2226f5531f3d0a57c997a54c56ec57ba343b438fbeddb29704cfb29328ee99
MISC metadata.xml 344 BLAKE2B 3dd1aba1bed81c9993d1d9527e5695c4538c32014dc4da3303c602031182421f50629296c69f2f821455d29a0beb01a94b86541421d31462d37b05bbd57b41f0 SHA512 8fddf2b64d5dbdc79ccc206e36e33c2aee2c17ffc1c6012c80431d3d487734538c6efc3e3b6803407535783b1afa91901b929220874f8d20ce2616ad6cdb967d
diff --git a/sys-cluster/crmsh/crmsh-4.5.0.ebuild b/sys-cluster/crmsh/crmsh-4.5.0.ebuild
new file mode 100644
index 000000000000..02b052288712
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-r3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-2.1.2"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_optimize
+}