summaryrefslogtreecommitdiff
path: root/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild')
-rw-r--r--sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
new file mode 100644
index 000000000000..d3e78fcdc3cd
--- /dev/null
+++ b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils versionator multilib
+
+MY_P=cluster-${PV}
+
+MAJ_PV=$(get_major_version)
+MIN_PV=$(get_version_component_range 2).$(get_version_component_range 3)
+
+DESCRIPTION="A library for cluster management common to the various pieces of Cluster Suite"
+HOMEPAGE="https://sourceware.org/cluster/wiki/"
+SRC_URI="ftp://sourceware.org/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="!sys-cluster/cman-headers
+ !sys-cluster/cman-kernel
+ !=sys-cluster/cman-1*"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/${PN/-//}
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc="$(tc-getCC)" \
+ --libdir=/usr/$(get_libdir) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ ) || die "configure problem"
+
+ sed -e 's:\($(CC)\):\1 $(LDFLAGS):' \
+ -i Makefile "${WORKDIR}/${MY_P}/make/cobj.mk" || die
+
+ emake clean all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}