summaryrefslogtreecommitdiff
path: root/sys-cluster/classads/classads-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /sys-cluster/classads/classads-1.0.10.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'sys-cluster/classads/classads-1.0.10.ebuild')
-rw-r--r--sys-cluster/classads/classads-1.0.10.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/sys-cluster/classads/classads-1.0.10.ebuild b/sys-cluster/classads/classads-1.0.10.ebuild
index 72ea735ea47f..4b692bd26e3e 100644
--- a/sys-cluster/classads/classads-1.0.10.ebuild
+++ b/sys-cluster/classads/classads-1.0.10.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Condor's classified advertisement language"
HOMEPAGE="http://www.cs.wisc.edu/condor/classad/"
@@ -11,15 +12,26 @@ SRC_URI="ftp://ftp.cs.wisc.edu/condor/classad/c++/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="pcre static-libs"
+IUSE="pcre"
RDEPEND="pcre? ( dev-libs/libpcre )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- myeconfargs+=(
- --enable-namespace
+ econf \
+ --disable-static \
+ --enable-namespace \
--enable-flexible-member
- )
- autotools-utils_src_configure
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}