summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 03:33:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 03:33:50 +0100
commit9b97cf60d2411c33c1b2170b730b345ea9995002 (patch)
tree20f1731a35de056eaa5e40343e8aa59e6d1cc564 /sys-cluster/ceph/files
parent9cb92979365e38a8c7ac40e7fd7475b99fe1e7ba (diff)
gentoo auto-resync : 11:08:2023 - 03:33:50
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-18.2.0-cyclic-deps.patch13
-rw-r--r--sys-cluster/ceph/files/ceph-18.2.0-system-opentelemetry.patch19
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-18.2.0-cyclic-deps.patch b/sys-cluster/ceph/files/ceph-18.2.0-cyclic-deps.patch
new file mode 100644
index 000000000000..af9caa63aed2
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-18.2.0-cyclic-deps.patch
@@ -0,0 +1,13 @@
+diff --git a/src/rgw/driver/dbstore/CMakeLists.txt b/src/rgw/driver/dbstore/CMakeLists.txt
+index a3aca7a64e4..072d20193e3 100644
+--- a/src/rgw/driver/dbstore/CMakeLists.txt
++++ b/src/rgw/driver/dbstore/CMakeLists.txt
+@@ -24,7 +24,7 @@ set(dbstore_mgr_srcs
+ dbstore_mgr.cc
+ )
+
+-add_library(dbstore_lib ${dbstore_srcs})
++ add_library(dbstore_lib STATIC ${dbstore_srcs})
+ target_include_directories(dbstore_lib
+ PUBLIC "${CMAKE_SOURCE_DIR}/src/rgw"
+ PUBLIC "${CMAKE_SOURCE_DIR}/src/rgw/store/rados"
diff --git a/sys-cluster/ceph/files/ceph-18.2.0-system-opentelemetry.patch b/sys-cluster/ceph/files/ceph-18.2.0-system-opentelemetry.patch
new file mode 100644
index 000000000000..5e92d491dba9
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-18.2.0-system-opentelemetry.patch
@@ -0,0 +1,19 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0a841c5db37..29be0232b48 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -433,8 +433,12 @@ add_dependencies(common-objs legacy-option-headers)
+
+ if(WITH_JAEGER)
+ find_package(thrift 0.13.0 REQUIRED)
+- include(BuildOpentelemetry)
+- build_opentelemetry()
++ find_package(opentelemetry-cpp REQUIRED)
++ set(jaeger_base
++ opentelemetry-cpp::common
++ opentelemetry-cpp::trace
++ opentelemetry-cpp::jaeger_trace_exporter
++ thrift::libthrift)
+ add_library(jaeger_base INTERFACE)
+ target_link_libraries(jaeger_base INTERFACE opentelemetry::libopentelemetry
+ thrift::libthrift)