summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-cluster/ceph/files
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.2-no-virtualenvs.patch74
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch53
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch69
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-findre2.patch22
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-fuse3.patch13
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch12
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch68
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-osd_class_dir.patch13
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch26
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch20
10 files changed, 296 insertions, 74 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.2-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-16.2.2-no-virtualenvs.patch
deleted file mode 100644
index fa865529d424..000000000000
--- a/sys-cluster/ceph/files/ceph-16.2.2-no-virtualenvs.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
-index d26d003c77..bc962e3aa7 100644
---- a/cmake/modules/AddCephTest.cmake
-+++ b/cmake/modules/AddCephTest.cmake
-@@ -70,14 +70,6 @@ function(add_tox_test name)
- endif()
- string(REPLACE ";" "," tox_envs "${tox_envs}")
- find_package(Python3 QUIET REQUIRED)
-- add_custom_command(
-- OUTPUT ${venv_path}/bin/activate
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python="${Python3_EXECUTABLE}" ${venv_path}
-- WORKING_DIRECTORY ${tox_path}
-- COMMENT "preparing venv for ${name}")
-- add_custom_target(${name}-venv
-- DEPENDS ${venv_path}/bin/activate)
-- add_dependencies(tests ${name}-venv)
- add_test(
- NAME ${test_name}
- COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
-diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
-index 4224499c47..9a6c87595b 100644
---- a/src/ceph-volume/CMakeLists.txt
-+++ b/src/ceph-volume/CMakeLists.txt
-@@ -8,22 +8,6 @@ if(FREEBSD)
- add_subdirectory(plugin/zfs)
- endif()
-
--# Required for running ceph-volume inventory in a vstart environment
--set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
--
--add_custom_command(
-- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
-- COMMENT "ceph-volume venv is being created")
--
--add_custom_command(
-- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
-- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
-- COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
-- COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
--
- add_custom_target(ceph-volume-venv-setup
- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
-
-diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index 94c0a56827..7f63e2adf4 100644
---- a/src/pybind/mgr/dashboard/CMakeLists.txt
-+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
-@@ -5,9 +5,6 @@ function(add_npm_command)
- set(multi_kw COMMAND DEPENDS)
- cmake_parse_arguments(NC "${options}" "${single_kw}" "${multi_kw}" ${ARGN})
- string(REPLACE ";" " " command "${NC_COMMAND}")
-- if(NC_NODEENV)
-- string(REGEX REPLACE "^(.*(npm|npx) .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-- endif()
- string(REPLACE " " ";" command "${command}")
- add_custom_command(
- OUTPUT "${NC_OUTPUT}"
-@@ -51,11 +48,8 @@ else(WITH_SYSTEM_NPM)
- set(node_mirror_opt "--mirror=$ENV{NODE_MIRROR}")
- endif()
- add_custom_command(
-- OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv --verbose ${node_mirror_opt} -p --node=12.18.2
-- COMMAND mkdir ${mgr-dashboard-nodeenv-dir}/.npm
-+ OUTPUT "/bin/npm"
-+ COMMAND /bin/nodeenv ${node_mirror_opt} -p --node=12.18.2
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
- COMMENT "dashboard nodeenv is being installed"
- )
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
new file mode 100644
index 000000000000..f80edddd8de7
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
@@ -0,0 +1,53 @@
+From 78edb6a91788133334ceeeda0c95529df5f40da8 Mon Sep 17 00:00:00 2001
+From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
+Date: Mon, 14 Feb 2022 07:42:08 -0500
+Subject: [PATCH] rgw: cmake configure error on fedora-37/rawhide
+
+see
+https://kojipkgs.fedoraproject.org//work/tasks/6624/82706624/build.log,
+excerpted below
+
+...
+CMake Error: The inter-target dependency graph contains the following
+strongly connected component (cycle): "rgw_common" of type
+STATIC_LIBRARY depends on "dbstore" (weak) depends on "sqlite_db" (weak)
+"dbstore" of type SHARED_LIBRARY depends on "rgw_common" (weak) depends
+on "sqlite_db" (weak) "sqlite_db" of type SHARED_LIBRARY depends on
+"rgw_common" (weak) depends on "dbstore" (weak) At least one of these
+targets is not a STATIC_LIBRARY. Cyclic dependencies are allowed only
+among static libraries. CMake Generate step failed. Build files cannot
+be regenerated correctly.
+...
+
+https://tracker.ceph.com/issues/54266
+
+Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
+---
+ src/rgw/store/dbstore/CMakeLists.txt | 2 +-
+ src/rgw/store/dbstore/sqlite/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
+index 143ede3c094c9..18e032b73f54f 100644
+--- a/src/rgw/store/dbstore/CMakeLists.txt
++++ b/src/rgw/store/dbstore/CMakeLists.txt
+@@ -47,7 +47,7 @@ else()
+ endif()
+
+ include_directories(${CMAKE_INCLUDE_DIR})
+-add_library(dbstore ${dbstore_mgr_srcs})
++add_library(dbstore STATIC ${dbstore_mgr_srcs})
+ target_link_libraries(dbstore ${CMAKE_LINK_LIBRARIES})
+
+ # testing purpose
+diff --git a/src/rgw/store/dbstore/sqlite/CMakeLists.txt b/src/rgw/store/dbstore/sqlite/CMakeLists.txt
+index cce59b9ec0aa9..909765e3058b6 100644
+--- a/src/rgw/store/dbstore/sqlite/CMakeLists.txt
++++ b/src/rgw/store/dbstore/sqlite/CMakeLists.txt
+@@ -12,5 +12,5 @@ include_directories(${CMAKE_INCLUDE_DIR})
+ set(SQLITE_COMPILE_FLAGS "-DSQLITE_THREADSAFE=1")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SQLITE_COMPILE_FLAGS}")
+
+-add_library(sqlite_db ${sqlite_db_srcs})
++add_library(sqlite_db STATIC ${sqlite_db_srcs})
+ target_link_libraries(sqlite_db sqlite3 dbstore_lib rgw_common)
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch b/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch
new file mode 100644
index 000000000000..64b6d5c614c8
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch
@@ -0,0 +1,69 @@
+diff --git a/src/common/ConfUtils.cc b/src/common/ConfUtils.cc
+index ad791ece4f7..2f78fd02bf9 100644
+--- a/src/common/ConfUtils.cc
++++ b/src/common/ConfUtils.cc
+@@ -26,7 +26,7 @@
+ #include <boost/algorithm/string.hpp>
+ #include <boost/algorithm/string/trim_all.hpp>
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/spirit/include/support_line_pos_iterator.hpp>
+
+ #include "include/buffer.h"
+diff --git a/src/mds/MDSAuthCaps.cc b/src/mds/MDSAuthCaps.cc
+index b78ebd6615b..f8158be6866 100644
+--- a/src/mds/MDSAuthCaps.cc
++++ b/src/mds/MDSAuthCaps.cc
+@@ -17,8 +17,8 @@
+ #include <errno.h>
+
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix_operator.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix/operator.hpp>
++#include <boost/phoenix.hpp>
+
+ #include "common/debug.h"
+ #include "MDSAuthCaps.h"
+diff --git a/src/mgr/MgrCap.cc b/src/mgr/MgrCap.cc
+index cba758083c3..6e5e1f9bb99 100644
+--- a/src/mgr/MgrCap.cc
++++ b/src/mgr/MgrCap.cc
+@@ -16,7 +16,7 @@
+ #include <boost/spirit/include/qi_uint.hpp>
+ #include <boost/spirit/include/qi.hpp>
+ #include <boost/fusion/include/std_pair.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/fusion/adapted/struct/adapt_struct.hpp>
+ #include <boost/fusion/include/adapt_struct.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+diff --git a/src/mon/MonCap.cc b/src/mon/MonCap.cc
+index e1dc3723965..0ff9fefdd15 100644
+--- a/src/mon/MonCap.cc
++++ b/src/mon/MonCap.cc
+@@ -16,7 +16,7 @@
+ #include <boost/spirit/include/qi_uint.hpp>
+ #include <boost/spirit/include/qi.hpp>
+ #include <boost/fusion/include/std_pair.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/fusion/adapted/struct/adapt_struct.hpp>
+ #include <boost/fusion/include/adapt_struct.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+diff --git a/src/osd/OSDCap.cc b/src/osd/OSDCap.cc
+index e7bf0582799..f847e80e337 100644
+--- a/src/osd/OSDCap.cc
++++ b/src/osd/OSDCap.cc
+@@ -14,8 +14,8 @@
+
+ #include <boost/config/warning_disable.hpp>
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix_operator.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix/operator.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+
+ #include "OSDCap.h"
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch b/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch
new file mode 100644
index 000000000000..e42f291e55bf
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch
@@ -0,0 +1,22 @@
+diff --git a/src/arrow/cpp/cmake_modules/Findre2.cmake b/src/arrow/cpp/cmake_modules/Findre2.cmake
+new file mode 100644
+index 00000000000..6f39de75461
+--- /dev/null
++++ b/src/arrow/cpp/cmake_modules/Findre2.cmake
+@@ -0,0 +1,16 @@
++FIND_PATH(SYSTEM_RE2_INCLUDE_DIR re2/re2.h)
++IF (SYSTEM_RE2_INCLUDE_DIR)
++ MESSAGE(STATUS "Found RE2 include dir")
++ FIND_LIBRARY(SYSTEM_RE2_LIBRARY re2)
++ IF (SYSTEM_RE2_LIBRARY)
++ MESSAGE(STATUS "Found RE2 library")
++ SET(RE2_INCLUDE_DIR ${SYSTEM_RE2_INCLUDE_DIR})
++ SET(RE2_LIBRARY ${SYSTEM_RE2_LIBRARY})
++ ELSE ()
++ MESSAGE(FATAL_ERROR "Found RE2 headers, but not the library")
++ ENDIF ()
++ELSE ()
++ MESSAGE(STATUS "Did not find system RE2")
++ENDIF ()
++
++
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-fuse3.patch b/sys-cluster/ceph/files/ceph-17.2.0-fuse3.patch
new file mode 100644
index 000000000000..59b2be6ffd80
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-fuse3.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e95019cedb2..814c7f4d0b7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -178,7 +178,7 @@ endif()
+
+ option(WITH_FUSE "Fuse is here" ON)
+ if(WITH_FUSE)
+- find_package(FUSE)
++ find_package(FUSE 3.0)
+ set(HAVE_LIBFUSE ${FUSE_FOUND})
+ endif()
+
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
new file mode 100644
index 000000000000..e50030071c81
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
@@ -0,0 +1,12 @@
+diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
+index 143ede3c094..204ef653010 100644
+--- a/src/rgw/store/dbstore/CMakeLists.txt
++++ b/src/rgw/store/dbstore/CMakeLists.txt
+@@ -24,6 +24,7 @@ if(WITH_JAEGER)
+ list(APPEND link_targets ${jaeger_base})
+ endif()
+ target_link_libraries(dbstore_lib PUBLIC ${link_targets})
++install(TARGETS dbstore_lib DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} dbstore_lib)
+
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch
new file mode 100644
index 000000000000..930dd08e8630
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch
@@ -0,0 +1,68 @@
+diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
+index 0df7125b508..01afc88289c 100644
+--- a/cmake/modules/AddCephTest.cmake
++++ b/cmake/modules/AddCephTest.cmake
+@@ -57,7 +57,6 @@ endfunction()
+
+ function(add_tox_test name)
+ set(test_name run-tox-${name})
+- set(venv_path ${CEPH_BUILD_VIRTUALENV}/${name}-virtualenv)
+ cmake_parse_arguments(TOXTEST "" "TOX_PATH" "TOX_ENVS" ${ARGN})
+ if(DEFINED TOXTEST_TOX_PATH)
+ set(tox_path ${TOXTEST_TOX_PATH})
+@@ -71,27 +70,13 @@ function(add_tox_test name)
+ endif()
+ string(REPLACE ";" "," tox_envs "${tox_envs}")
+ find_package(Python3 QUIET REQUIRED)
+- add_test(
+- NAME setup-venv-for-${name}
+- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${venv_path}
+- WORKING_DIRECTORY ${tox_path})
+- set_tests_properties(setup-venv-for-${name} PROPERTIES
+- FIXTURES_SETUP venv-for-${name})
+- add_test(
+- NAME teardown-venv-for-${name}
+- COMMAND ${CMAKE_COMMAND} -E remove_directory ${venv_path})
+- set_tests_properties(teardown-venv-for-${name} PROPERTIES
+- FIXTURES_CLEANUP venv-for-${name})
+ add_test(
+ NAME ${test_name}
+ COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
+ --source-dir ${CMAKE_SOURCE_DIR}
+ --build-dir ${CMAKE_BINARY_DIR}
+ --tox-path ${tox_path}
+- --tox-envs ${tox_envs}
+- --venv-path ${venv_path})
+- set_tests_properties(${test_name} PROPERTIES
+- FIXTURES_REQUIRED venv-for-${name})
++ --tox-envs ${tox_envs})
+ set_property(
+ TEST ${test_name}
+ PROPERTY ENVIRONMENT
+diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
+index 9166553dc73..9a6c87595b9 100644
+--- a/src/ceph-volume/CMakeLists.txt
++++ b/src/ceph-volume/CMakeLists.txt
+@@ -8,22 +8,6 @@ if(FREEBSD)
+ add_subdirectory(plugin/zfs)
+ endif()
+
+-# Required for running ceph-volume inventory in a vstart environment
+-set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
+-
+-add_custom_command(
+- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
+- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+- COMMENT "ceph-volume venv is being created")
+-
+-add_custom_command(
+- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
+- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
+- COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+- COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
+-
+ add_custom_target(ceph-volume-venv-setup
+ DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
+
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-osd_class_dir.patch b/sys-cluster/ceph/files/ceph-17.2.0-osd_class_dir.patch
new file mode 100644
index 000000000000..2f6afc32cbc1
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-osd_class_dir.patch
@@ -0,0 +1,13 @@
+diff --git a/src/common/options/osd.yaml.in b/src/common/options/osd.yaml.in
+index 8360e4a9223..e176fd37e06 100644
+--- a/src/common/options/osd.yaml.in
++++ b/src/common/options/osd.yaml.in
+@@ -451,7 +451,7 @@ options:
+ - name: osd_class_dir
+ type: str
+ level: advanced
+- default: @CMAKE_INSTALL_LIBDIR@/rados-classes
++ default: @CMAKE_INSTALL_FULL_LIBDIR@/rados-classes
+ fmt_desc: The class path for RADOS class plug-ins.
+ with_legacy: true
+ - name: osd_open_classes_on_start
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
new file mode 100644
index 000000000000..8591b0bc7f89
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
@@ -0,0 +1,26 @@
+diff --git a/src/pybind/CMakeLists.txt b/src/pybind/CMakeLists.txt
+index cd9b27623d2..12688ad32b9 100644
+--- a/src/pybind/CMakeLists.txt
++++ b/src/pybind/CMakeLists.txt
+@@ -36,6 +36,10 @@ execute_process(
+ OUTPUT_VARIABLE "PYTHON3_INSTDIR"
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++if(Boost_VERSION VERSION_GREATER_EQUAL 1.74)
++ add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++endif()
++
+ install(FILES
+ ceph_argparse.py
+ ceph_daemon.py
+diff --git a/src/test/librados/CMakeLists.txt b/src/test/librados/CMakeLists.txt
+index fc033766cc4..0ba3bc56e98 100644
+--- a/src/test/librados/CMakeLists.txt
++++ b/src/test/librados/CMakeLists.txt
+@@ -1,3 +1,6 @@
++
++add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++
+ # radostest
+ add_library(radostest_shared OBJECT test_shared.cc)
+ target_include_directories(radostest_shared PRIVATE
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch b/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch
new file mode 100644
index 000000000000..6e0788a093e5
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch
@@ -0,0 +1,20 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 30cf3605468..902e2123d04 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -430,9 +430,12 @@ add_dependencies(common-objs legacy-option-headers)
+
+ if(WITH_JAEGER)
+ find_package(thrift 0.13.0 REQUIRED)
+- include(BuildOpentelemetry)
+- build_opentelemetry()
+- set(jaeger_base opentelemetry::libopentelemetry thrift::libthrift)
++ find_package(opentelemetry-cpp 1.3.0 REQUIRED)
++ set(jaeger_base
++ opentelemetry-cpp::common
++ opentelemetry-cpp::trace
++ opentelemetry-cpp::jaeger_trace_exporter
++ thrift::libthrift)
+ add_dependencies(common-objs ${jaeger_base})
+ target_link_libraries(common-objs ${jaeger_base})
+ endif()