summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
commitd56d144655e3785864da43c9acb6c228ef9360ae (patch)
treeb769b599a558483f82e9a057c41f1edd29626dd1 /sys-boot
parentfab849d1daed0ba7f2ac497d07985c3dbb692543 (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin7225 -> 7227 bytes
-rw-r--r--sys-boot/mbr-gpt/Manifest4
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild53
-rw-r--r--sys-boot/mbr-gpt/metadata.xml4
4 files changed, 6 insertions, 55 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index ba3eba93b24b..5a116ac80654 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
index 7828528540cd..b04316979f7b 100644
--- a/sys-boot/mbr-gpt/Manifest
+++ b/sys-boot/mbr-gpt/Manifest
@@ -1,3 +1,3 @@
DIST mbr-gpt_0.0.1.tar.gz 15861 BLAKE2B 00c6741fa5543af435cee97132510126d0301db2fb50712d438703165507125b4981844cb4a841b11bad075af5effb746fd3aa04e6834fb051536b250c01f7ad SHA512 eaabd84fc749ddee8fa40632ad49e15e894bf35a881fb7c35ba22796c2459a886e9bda601595e58d29567ff26959ae2befe6aec5db397d15e1dc5a292dafe165
-EBUILD mbr-gpt-0.0.1.ebuild 1397 BLAKE2B 9b2f00d948d769fe93fcde67ffcbd572a3d43da34667f1ad0ba5a3c5566655a3454cdbaef5e1b1f9f0ba95cd5d015ce2be623d250fb640a645bb60d3df0ab1ad SHA512 4d5e180360b4b165e47fe43dccbef74598505949c79b753e1ad61d76494b6fd8a39649a2f69ef49b2e1ad7403ba87a699b51285d7db0a9edd00425b09dc76641
-MISC metadata.xml 329 BLAKE2B d3b79b0a53a4a98cf288ff1ee8ae8cb477b90dad4529cedf04a52b25a3fc359121851c2cea28d703b2d2a42c5813bfe9b84398786e9045521eaff01b94f543c4 SHA512 3baca06564c2219ea6175ea39cea467ada4e7bf21a4341fcdc9d5b885ae387f4ca4f93605464b900a2524d64badfae641c5459d0acd0569de1ce848528a46ee4
+EBUILD mbr-gpt-0.0.1-r1.ebuild 1717 BLAKE2B fce8f14214f23a410e9ea4d5223007044520cc9fbffa35408890227026b9f7c225c843bcdabdf9ba1f64c520710aef86953e66637de5f96fadaebc45428ed71d SHA512 e22f7b02ddd887d41b4a8f5b5d9076b6bfd45cd0235f2826370c587921e963e91704474ba35db53aa6343dae12040f17ed810e6315734446ee1aca4f5812f0bb
+MISC metadata.xml 665 BLAKE2B ad75295ccf49280adce38241b7d2b09ea5461e9aafaa63f6e33eaa35b4639f91535b9ebd4212e91f832020e38ed8f638e03dc6629c6d74490548866b9d58a497 SHA512 b2b28b150ab2f6a983b82216b6d900e2a2893872092dfb8e2e608899c76e182cd581528311e0135177e60b576bca3f9923bd7eb0e54d9d7a8a434b4c87fa6883
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
deleted file mode 100644
index 034062e65135..000000000000
--- a/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="An MBR that can handle BIOS-based boot on GPT"
-MY_P="${PN}_${PV}"
-HOMEPAGE="http://aybabtu.com/mbr-gpt/"
-SRC_URI="http://aybabtu.com/mbr-gpt/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
-# It's also pure ASM, so not suitable for elsewhere anyway.
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-# It only depends on binutils/gcc/make, and doesn't link against libc even.
-DEPEND=""
-RDEPEND=""
-
-# It's a mostly an MBR block and it does use the executable stack.
-QA_WX_LOAD="usr/sbin/boot.elf"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- emake clean
-
- # Need to build it 32-bit for the MBR
- # Btw, no CFLAGS are respected, it's ASM!
- use amd64 && sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- # get_libdir is not correct here. We want this to go into a 32-bit library
- # location.
- insinto /usr/lib/mbr-gpt/
- doins mbr
- dosbin boot.elf
- dodoc AUTHORS
-}
-
-pkg_postinst() {
- einfo "See the instructions on the homepage, and make sure you know what"
- einfo "you are doing before touching this. The mbr file does into your"
- einfo "MBR, or alternatively you can do a creative reboot utilizing the"
- einfo "boot.elf binary."
-}
diff --git a/sys-boot/mbr-gpt/metadata.xml b/sys-boot/mbr-gpt/metadata.xml
index 9590fe15fc00..92a82843d1a5 100644
--- a/sys-boot/mbr-gpt/metadata.xml
+++ b/sys-boot/mbr-gpt/metadata.xml
@@ -8,4 +8,8 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
+<longdescription lang="en">
+ Bootable MBR including fake partition records, for legacy BIOS without any GPT support, and usable without hybrid disk layouts.
+ Install directly at the start of a disk, create GPT, ensure at least one partition has GUID set to BIOS Boot Partition (21686148-6449-6e6f-744e-656564454649).
+</longdescription>
</pkgmetadata>