summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 12:31:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 12:31:21 +0100
commit7e8f29e487b79a183d66ca22f1e54dab5c47a409 (patch)
tree1aaa96a96a9f9ee78350986f9f8cb8b23fcb1c5f /sys-boot
parent7a36a65c987a298331a241fb01e229665e4983cd (diff)
gentoo auto-resync : 09:04:2024 - 12:31:21
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5730 -> 5900 bytes
-rw-r--r--sys-boot/uefi-mkconfig/Manifest3
-rw-r--r--sys-boot/uefi-mkconfig/metadata.xml16
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild35
4 files changed, 54 insertions, 0 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 9ec88714d892..2cefcebde643 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
new file mode 100644
index 000000000000..5ad46ac09914
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -0,0 +1,3 @@
+DIST uefi-mkconfig-1.4.tar.gz 7844 BLAKE2B 4266c8c934f665c85d54699ebdd11648692b1eff2e0d4111de8329e01dee3342c760d772da27a8862e0427fcbecb38a9c0499ee482aa1ee0dcf72d0f30be97ef SHA512 47e096571899c18decd24c65df9bdd9da964e1e47120504d8c9761b7c2b80172b17a9259f229c267c95d7ee4ac24a1e79a3d0f13d15fc2effee7fcee8b1ce3ea
+EBUILD uefi-mkconfig-1.4.ebuild 922 BLAKE2B 21d05493bcfad414955c7635a977ebb97f1e3666d33dc9d0e1b28e8564d68756753ebcfc15f0221f96af25ab8b1d03a06080b11560e05ec84354f0238f706302 SHA512 87859855a7646316c0556c552eadc3418bc0ee8f7d15ce5a4393295720f98e7a7b17daa4188746e9eece1f4b8939329b2c67aa2fc1db2e2b9acb3e4e7a3b7f90
+MISC metadata.xml 547 BLAKE2B fb91c84c4c6542e1f61e428d43a16253053892f1d2588f1732ffcb62695afe6c1ef94ddb5a71157caae8b4ec98a760143263b1d5768143403d9910bbd1ea8def SHA512 f0f49933219ebedda34a856089e1be5642608c2464ba6d7819da00ce25bd5a19ac41a1cbfd927937a4bbbf0d500e4271394da28d31428fc8482c35bcf61cc3e7
diff --git a/sys-boot/uefi-mkconfig/metadata.xml b/sys-boot/uefi-mkconfig/metadata.xml
new file mode 100644
index 000000000000..449694d29242
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jakub@gdos.sk</email>
+ <name>Jakub GajdoĊĦ</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Biosias/uefi-mkconfig</remote-id>
+ <bugs-to>https://github.com/Biosias/uefi-mkconfig/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild
new file mode 100644
index 000000000000..0729f2e0a75f
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}