summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-29 19:13:18 +0000
commit62090949b4fde34bbcbb4bd770a9635c6ac0c55e (patch)
tree2af5001a82f05c858f1e80e2231929c173a8bb55 /sys-boot
parent04a447f4f2679e9687093f49d8a9ea911fac9a9b (diff)
gentoo auto-resync : 29:03:2024 - 19:13:18
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5727 -> 5724 bytes
-rw-r--r--sys-boot/colo/Manifest1
-rw-r--r--sys-boot/colo/colo-1.22-r1.ebuild121
3 files changed, 122 insertions, 0 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 747d328a12a7..9b241f4fe25b 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index b1e8ab0cfcac..8c35251211df 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -3,5 +3,6 @@ AUX default.colo 840 BLAKE2B a97a6a0d121edccf49842c0b14f3b4d48e0e12d92c7a40e3a78
AUX menu.colo 1517 BLAKE2B 04d4ea5118ebe89229607a9beb8f6713a40f945df1d3ae0de867eed4cbf1df7be9ad30ddcc0a24a2489de1719424ea77d24a0c66ed42f6ce9da97b9bf175bd60 SHA512 a7357e176f45d5d352ea450349986ae5493900d60b363f688371348b727859d7be9b2a732e5210beba5216bfa8b8e6c861f2433573a009aabb71569eefcc5eaa
AUX simple.colo 539 BLAKE2B fa8a255ffeac0ad14c0fc392fe65e89c9e627c022d0adbd9e1b1add70cc0535b9837f45d59ea1b43ae6919637a36c5364d38e75d4b5be7102e5dbf2c1727565d SHA512 38b3481adbad50c344f87cfd9a5346a78158cfd298194f715b40ad582d5fad9ad6e16f773004a8732e673bc8b3791dde39da10ac85c72a8e236837ca82a91d1a
DIST colo-1.22.tar.gz 257968 BLAKE2B f7c8f97b3fed2d2071b89f84e3e78e814914999a3038c854d92e651e4c3a1aa1889e3486f2de94c561475befe4e4a4606e4873c4174ff0b24dcc290f494f5acb SHA512 c983f36991a6275d4864cbd12e00f4e73d3b722746b3d3c8442afc8fe00d5432772c93007999858afb0993e1a4917f94bc9803f017ace3e65535cad7e8fb9b1e
+EBUILD colo-1.22-r1.ebuild 3863 BLAKE2B f2beeaf8541e1f039ac21f19730c73dc71a00d292c7ac7358f43930982e51da554567aeb11398ccfd696a1cef67744438a5627cee6075f2060233a48ef67b255 SHA512 d6ee27fa5e0ebc75695264a74ceeaa070c5d3c94ca52ff5d6df229a1d4a782b2fe11b560c3dfb8a3cee0a2eca457579cf48e9a1be02b31003d2619ada5041179
EBUILD colo-1.22.ebuild 3828 BLAKE2B b19a039f1b6561dc002a7fcc13c0d8bc0dc0480d62d1e7570c6de66a90a857dcc484e49aba4e5bd9cac007ddbeef12cc67baaa2580f125de3b21f28a91e19aac SHA512 0ffc7656eafa560b5eeb5d6e501e49c07faf211232e062ba41eb8d7b3cd07e64223448554550c9c57bc2920d2a166b757b48f6f21cb559c806c9ef4341763cbe
MISC metadata.xml 255 BLAKE2B 38f74d4046b8cadf4d1f04a3c35a7b1dc04a47c8658533c1bc8e2d69da08458084cd52dd84757f3e9fd8368c98f47cbbbf1e4fa24a800aacb55bbed34b83f1f6 SHA512 08802a1297d8dbe5915854d495674e1d9835e664ecb645908b90490c57ab7fc2f6a1ee9b994c45716465dc450ff4dcedf51e575498ec0d6b5a31176c58de1775
diff --git a/sys-boot/colo/colo-1.22-r1.ebuild b/sys-boot/colo/colo-1.22-r1.ebuild
new file mode 100644
index 000000000000..3bd8c4f9c121
--- /dev/null
+++ b/sys-boot/colo/colo-1.22-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="https://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="https://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+
+RESTRICT="strip"
+
+src_prepare() {
+ eapply "${FILESDIR}"/colo-stage2_src_heap-fix.patch
+ sed -E -i -e "s/CFLAGS_COLO=/CFLAGS_COLO:=/g" -e "/[A-Z]+= /d" Rules.mak || die # bug 725846
+ default
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building the CoLo Bootloader ..."
+
+ # Remove -Werror from CFLAGS
+ # gcc-4.3.x is more strict; We'll go back and fix later
+ cd "${S}" || die
+ local x
+ for x in $(grep -rl "Werror" "${S}"/*); do
+ sed -i -e 's/\-Werror//g' "${x}" || die
+ done
+
+ # Keep elf2rfx from automatically building via the Makefile
+ sed -i -e 's/tools\/elf2rfx //' "${S}"/Makefile || die
+
+ # Build it first with BUILD_CC in case of cross-compiles
+ cd "${S}"/tools/elf2rfx || die
+ make CC="$(tc-getBUILD_CC)" || die
+
+ # Build the rest
+ cd "${S}" || die
+ make clean || die # emake breaks the build
+ make CC="$(tc-getCC)" OBJCOPY="$(tc-getOBJCOPY)" \
+ STRIP="$(tc-getSTRIP)" || die
+
+ # Now rebuild elf2rfx again with CC so it can be installed
+ cd "${S}"/tools/elf2rfx || die
+ make clean || die
+ make CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ # bins
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf "${D}"/usr/lib/colo || die
+ cp binaries/colo-rom-image.bin "${D}"/usr/lib/colo || die
+
+ # docs
+ dodoc CHANGES INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+
+ # all tools except lcdtools (see below)
+ local tool
+ for tool in flash-tool colo-perm copy-rom elf2rfx; do
+
+ einfo "Installing ${tool} binary to ${D}/usr/sbin"
+ dosbin tools/${tool}/${tool}
+ if [[ -f tools/${tool}/${tool}.8 ]]; then
+ einfo "Installing ${tool} manpage to ${D}/usr/share/man"
+ doman tools/flash-tool/flash-tool.8
+ fi
+
+ done
+
+ # lcdtools
+ for tool in paneld putlcd e2fsck-lcd; do
+ einfo "Installing ${tool} binary and manpage to ${D}/usr/sbin"
+ dosbin tools/lcdtools/${tool}/${tool}
+ doman tools/lcdtools/${tool}/${tool}.8
+ done
+ dolib.a tools/lcdtools/liblcd/liblcd.a
+
+ # bootscripts
+ dodir /usr/lib/colo/scripts
+ cp "${FILESDIR}"/*.colo "${D}"/usr/lib/colo/scripts || die
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Install locations:"
+ einfo " Binaries:\t/usr/lib/${PN}"
+ einfo " Docs:\t/usr/share/doc/${PF}"
+ einfo " Tools:\t/usr/sbin/{flash-tool,colo-perm,copy-rom,"
+ einfo " \tputlcd,paneld,e2fsck-lcd,elf2rfx}"
+ einfo " Scripts:\t/usr/lib/${PN}/scripts"
+ echo -e ""
+ einfo "Please read the docs to fully understand the behavior of this bootloader, and"
+ einfo "edit the boot scripts to suit your needs."
+ echo -e ""
+ ewarn "Users installing ${PN} for the first time need to be aware that newer"
+ ewarn "versions of ${PN} disable the serial port by default. If the serial port"
+ ewarn "is needed, select it from the boot menu. Users using the example boot"
+ ewarn "scripts provided will have the serial port automatically enabled."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}