summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
commit1f00990debeffd0052c194989d0a02baac23eb96 (patch)
treeecc3dfafe935354404f7a0689a6ad809ebaba580 /sys-boot
parent02eb6576978c38afed5787f6f2dbab8353379d66 (diff)
gentoo auto-resync : 22:04:2024 - 23:59:31
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5904 -> 5905 bytes
-rw-r--r--sys-boot/uefi-mkconfig/Manifest2
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild35
3 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index 2582f1ad4d02..2743e21fc858 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index 58985ae4173a..d7a260133e80 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1,3 +1,5 @@
DIST uefi-mkconfig-1.4.tar.gz 7844 BLAKE2B 4266c8c934f665c85d54699ebdd11648692b1eff2e0d4111de8329e01dee3342c760d772da27a8862e0427fcbecb38a9c0499ee482aa1ee0dcf72d0f30be97ef SHA512 47e096571899c18decd24c65df9bdd9da964e1e47120504d8c9761b7c2b80172b17a9259f229c267c95d7ee4ac24a1e79a3d0f13d15fc2effee7fcee8b1ce3ea
+DIST uefi-mkconfig-1.5.tar.gz 8299 BLAKE2B f06ec90f298f2dcc5c3001f603b50c7521b5568272ba263b87f19ed45f5d10aec162b8ad909c9c5bbe72638559b9346f586063e7e25c33c7b41b3fe881bab35f SHA512 244d280a0b2b8e197b9d9a46e4db729efb5d568a0907c538aa1e27e0491eb12e2105bfc6d7b52c2a06f7fd53f7c5d339d680124a9dbfb5bd451b8659ea23752f
EBUILD uefi-mkconfig-1.4.ebuild 939 BLAKE2B b5c54503a23ed7b7959d4e9840fd9a087d812e6540d1db613c1880bcc1a54038feedb6a3274f557b9cc151644e14303da26b131e22cc212ba2e95db9bee9b7af SHA512 d068b0f70fe9d0eb489c65b90aa187dd259b68542d850a6a715dfc9a3a5101b98d79d41e702fed6c8f632495c79ae958b3a224867046bed263a1bfaf036875b8
+EBUILD uefi-mkconfig-1.5.ebuild 939 BLAKE2B b5c54503a23ed7b7959d4e9840fd9a087d812e6540d1db613c1880bcc1a54038feedb6a3274f557b9cc151644e14303da26b131e22cc212ba2e95db9bee9b7af SHA512 d068b0f70fe9d0eb489c65b90aa187dd259b68542d850a6a715dfc9a3a5101b98d79d41e702fed6c8f632495c79ae958b3a224867046bed263a1bfaf036875b8
MISC metadata.xml 547 BLAKE2B fb91c84c4c6542e1f61e428d43a16253053892f1d2588f1732ffcb62695afe6c1ef94ddb5a71157caae8b4ec98a760143263b1d5768143403d9910bbd1ea8def SHA512 f0f49933219ebedda34a856089e1be5642608c2464ba6d7819da00ce25bd5a19ac41a1cbfd927937a4bbbf0d500e4271394da28d31428fc8482c35bcf61cc3e7
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild
new file mode 100644
index 000000000000..8e426c062c9c
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}