summaryrefslogtreecommitdiff
path: root/sys-boot/woeusb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-boot/woeusb
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-boot/woeusb')
-rw-r--r--sys-boot/woeusb/Manifest3
-rw-r--r--sys-boot/woeusb/metadata.xml10
-rw-r--r--sys-boot/woeusb/woeusb-3.1.5.ebuild58
3 files changed, 71 insertions, 0 deletions
diff --git a/sys-boot/woeusb/Manifest b/sys-boot/woeusb/Manifest
new file mode 100644
index 000000000000..9260d94a3858
--- /dev/null
+++ b/sys-boot/woeusb/Manifest
@@ -0,0 +1,3 @@
+DIST woeusb-3.1.5.tar.gz 399712 BLAKE2B d52b29249af680577299a02cb9a2c1436aef73a0240bff2525c494657c197a2fc0709e0ff6f35eb5d18592145347af284a998deacecff37effd95b75ab13bc9a SHA512 5cf4eb45b126d71bcb376148383faf9713bc06ec4ee3ccc2dfa6528d9fba382bceaae2cdd47f2d8ba775dad1ca8e6258af40fc6362336927894398193600c965
+EBUILD woeusb-3.1.5.ebuild 1038 BLAKE2B 37b0cbbb3becf15978702f8dd0e8d9d4deca181ccac043ba4448b8622d058aaa0f849fbebfb43f7b5c513749c4cf7383e0790d0501904d6569dc14361f18cde2 SHA512 5aa5d30c887963f1d4b6b7a1efec47635f2275c2fd8e1434360cd336f699e5b7e4df66b3aff19852eeb7150236a43d67b12ba4e681436f551939d084d5756c53
+MISC metadata.xml 280 BLAKE2B 6e0485a0da47b477f5276aa17735ff1e9b269dbac220b12c615a80a2ad5a7a6f88aa5bcc9bd715355b5687ba50d78bb0cc45d1ef0ba82c52111691b895cffc8e SHA512 af2aa2fda44a73779e31b805313371a2cb6b9ab2846289a73083074fbff99ea1e7da2fefeaccf13b5f11c4c55b6ccb38390f21eab3f4ac1a61e00914ae38fff9
diff --git a/sys-boot/woeusb/metadata.xml b/sys-boot/woeusb/metadata.xml
new file mode 100644
index 000000000000..8e2305513d49
--- /dev/null
+++ b/sys-boot/woeusb/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>pacho@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="minimal">Install only woeusb tool</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-boot/woeusb/woeusb-3.1.5.ebuild b/sys-boot/woeusb/woeusb-3.1.5.ebuild
new file mode 100644
index 000000000000..d1da40809082
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-3.1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/slacka/WoeUSB"
+SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+ sys-boot/grub:2[grub_platforms_pc]
+ !minimal? ( x11-libs/wxGTK:${WX_GTK_VER} )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
+ if ! use minimal; then
+ setup-wxwidgets
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ ! use minimal && default
+}
+
+src_compile() {
+ ! use minimal && default
+}
+
+src_test() {
+ ! use minimal && default
+}
+
+src_install() {
+ if use minimal; then
+ dosbin src/woeusb
+ einstalldocs
+ else
+ default
+ fi
+}