summaryrefslogtreecommitdiff
path: root/sys-boot/woeusb/woeusb-5.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-boot/woeusb/woeusb-5.1.2-r1.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-boot/woeusb/woeusb-5.1.2-r1.ebuild')
-rw-r--r--sys-boot/woeusb/woeusb-5.1.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-boot/woeusb/woeusb-5.1.2-r1.ebuild b/sys-boot/woeusb/woeusb-5.1.2-r1.ebuild
new file mode 100644
index 000000000000..4f1d25c96d02
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-5.1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/WoeUSB/WoeUSB"
+SRC_URI="https://github.com/WoeUSB/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/WoeUSB-${PV}"
+
+LICENSE="CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/wimlib
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2[grub_platforms_pc]
+ sys-fs/dosfstools
+ sys-fs/ntfs3g"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i "s/@@WOEUSB_VERSION@@/${PV}/" sbin/${PN} share/man/man1/${PN}.1 || die
+}
+
+src_install() {
+ dosbin sbin/${PN}
+ doman share/man/man1/${PN}.1
+
+ einstalldocs
+}