summaryrefslogtreecommitdiff
path: root/sys-boot/unetbootin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-boot/unetbootin
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/Manifest1
-rw-r--r--sys-boot/unetbootin/unetbootin-661-r1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index 6ec42fbf333b..0b63083cecf9 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1,5 +1,6 @@
AUX unetbootin-581-desktop.patch 707 BLAKE2B 9de8d50b00bbe6fe5968cb26f31aca08cf4dc8aa580a00b9af31e921a973ee62c6213b8154867902b61b5882377b8beddfbfa096ee7d4382f6adba05342b26cd SHA512 036f887c7fb4209cd08710be88ef25671e8c1e481e3d82bc78cc1e3b1480224573cbbbf8c290846373937863400ee108b72521c1d6a9a883e01209c1da33cae2
DIST unetbootin-661-qt5.patch.tar.xz 8060 BLAKE2B 58cb323166e344ecabf5d372e80ff0367a1344866a6e8dea4b2677a85ea6ae0b5591480a3bcbbfc3a51d391b07adf0d5f370ee77e4c7e1d6f2b727aedf274cf0 SHA512 c1226575484fa63c94ca4da875a26c7bd64bcb27d8e07ea5b67bb3f2546f31d1360d10c363cd7301476811e332c9524c96d6ba482c894b86a5b28ca8a1c8b385
DIST unetbootin-661.tar.gz 16257579 BLAKE2B 2f92cf286c8010a80d4d4cc48a7ece55e159af9f3729277d97eb99ef2ebe8945023d03c51d6e97d7101d8547240e3c2152004222ec4c825ef4ab954c4018e7b0 SHA512 bbf74a4c4ca9b52f4da672eb54524b7fcb796c65ba80700dc3c6f2677bde37574f42a11c213cc4d4eee38783aed650beee1e2894f60185745e509a2e9571f70a
+EBUILD unetbootin-661-r1.ebuild 2156 BLAKE2B f137242cd77cbe6d0befedbf8760bc02b3f6682b5ecaae2ecbbdce8f9cc4a92711cd01fe58c182f4c8dbf1d64ecab211722b43bfade2c1d186296d20fb6a2fa8 SHA512 43c1e45b25e042df1c48d7cf504021c21e16342550cf4ba83ff1de5c0c0466828b5d53deecf8eca4ba4ea22437b7fe057d98b9dcc3efab736cac7aa95c33338d
EBUILD unetbootin-661.ebuild 2089 BLAKE2B c1ecb3674dd00cb7359f33313c6886c24c38f0e84849cc6d04584f9a3b0e7a8954901f25bf7cb39148e9826cd77133a294610ba8b3d9f2a92eed7ff77c215040 SHA512 7c4c6c7d44bf0bd0c94b42c46d7c0660aabda97c8716f8035babc682b40acf001c5cebe47de8b9dbddde83fdf94fe5f86cf5479a3138ac75ab809f6ba11d610b
MISC metadata.xml 385 BLAKE2B 05836339f25bd812b23c8b93a6f05934a4bfa12d9fdd61f73140131c2d7609a5d1e257ed80c2cd983020720645e5444078cc71f2f51be9a2d435715e38ceea3f SHA512 9676e393ac2d18489433f0e658340a3eec0e01e0b35ca786540b07a6466f0b572f5d5bf115e6dc0b5c4898c00f630b9f5023f62f8e8f3a96c105bc74f918eb21
diff --git a/sys-boot/unetbootin/unetbootin-661-r1.ebuild b/sys-boot/unetbootin/unetbootin-661-r1.ebuild
new file mode 100644
index 000000000000..5363afc4eeca
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-661-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PATCHSET="${P}-qt5.patch.tar.xz"
+inherit desktop flag-o-matic qmake-utils
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+BDEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+"
+RDEPEND="${COMMON_DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-581-desktop.patch"
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}
+)
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ UNBN_QTPATH="$(qt5_get_bindir)/"
+ "${UNBN_QTPATH}"lrelease ${PN}.pro || die
+
+ eqmake5 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}