summaryrefslogtreecommitdiff
path: root/sys-boot/systemrescuecd-x86-grub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /sys-boot/systemrescuecd-x86-grub
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'sys-boot/systemrescuecd-x86-grub')
-rw-r--r--sys-boot/systemrescuecd-x86-grub/Manifest4
-rw-r--r--sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub10
-rw-r--r--sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild (renamed from sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild)5
3 files changed, 9 insertions, 10 deletions
diff --git a/sys-boot/systemrescuecd-x86-grub/Manifest b/sys-boot/systemrescuecd-x86-grub/Manifest
index 6205463b860c..1bda1f14830e 100644
--- a/sys-boot/systemrescuecd-x86-grub/Manifest
+++ b/sys-boot/systemrescuecd-x86-grub/Manifest
@@ -1,4 +1,4 @@
AUX systemrescuecd.default 845 BLAKE2B 85c0685cc80caa52874ebe61476beea84f06a83d5410db2b05f61dc30adc4a18a26790120a135988d6ff613672eff5e4ece89b20fc7185144317d8be325a5853 SHA512 81aebf9999cfe82696fc72f520fc88355fc8d3077a1c76858175f3367d33119db96c6cb639935b01d32ab1f1d0aaa1c41b7ea3b12e1c732e474de519cb50b2d6
-AUX systemrescuecd.grub 1910 BLAKE2B a2ff7040952b39f61c0c8fb4e2e61741abcc9190d444399c5872641ec5c55ac6acf573ffdfc6c0b86f57103a227639c2d57c95e0e9272ac82abf4272b2ecfd50 SHA512 34c8f4445589d58ddf0e0088184bfdc56f8fab19bbffc2cf0ac2646710eefe8b654066de196b3eb18377198dba38a2fa4b9a9b89f130a15a3ac2a94b75c7366e
-EBUILD systemrescuecd-x86-grub-0.1.ebuild 759 BLAKE2B 1390bd66c583d3c5f544d3add2edd3b3bfa2217be798421d081824e68f60e86158f777c4ed29d74a01bd1e7430c3fc0d5c3198311a6d2dbdf095903b28575839 SHA512 43ea43f4532f6ef3a69089aef6ca286fba2ebfee6c1fec9295c5fb37eb6c1c350de67fd37ccb8c2c428ed7cc2c8a18ca1cc83a4db2ea21f4dbf71fbf0e8d7900
+AUX systemrescuecd.grub 1910 BLAKE2B 46a3bf8c61e47e1f6eb3223ae44a2ac2e668603cb3ab1ab1fef7ee8626b365b8ac4a5f03f37b871f4b45952c33f7c940c1d20a317b759a1a90950a77eb54e21d SHA512 955a0fb35a034e60f005cbff27fc95e77622a0481d8111b3ee9981dbf0df4a6aa01f0e65307f98acee754dfe050b5e2cf2529b74a6f22f16e4f9164de359a915
+EBUILD systemrescuecd-x86-grub-0.1-r1.ebuild 751 BLAKE2B e6d0ec0b5efc360a33a1ae9a89d4636d6d180a62deee0473ac45095f21cf9df9071c11b43dcb3e8efd895c0ea358d857438e25da04abb0fede9c774bd13ed43f SHA512 bd7e7b3aba56c64d3d624f6b1f1108452f79836a3fdcee6b782272647025108218b71fc6c980c1482613cb23234107b2674bc73d57272e200ac4b161d7091911
MISC metadata.xml 610 BLAKE2B 2551878a7515db26498bab29653547aeef039e47292780ad7725606a618ca71384195e5b1e70e65e17085bae3651ee2602aef1e1479f47495f7efb783ac73816 SHA512 84101ca441d24894df8063a2d82ecf7f516bb6c3255d6b147b1448e27874f2ff634c5822f925a6648010fa83c6e75d60159237a44b99cd5a031e19174a17295d
diff --git a/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub b/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
index e9695c4b4821..269b1eb76adb 100644
--- a/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
+++ b/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
@@ -1,5 +1,5 @@
#!/bin/sh
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
. /usr/share/grub/grub-mkconfig_lib
@@ -32,28 +32,28 @@ if [ -f "${srcd}" ]; then
submenu "${longname}" --class submenu {
menuentry "${longname} (32bit standard${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/rescue32 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (64bit standard${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/rescue64 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (32bit alternative${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/altker32 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (64bit alternative${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/altker64 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
diff --git a/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild
index 3a5d11ae858b..80a820419133 100644
--- a/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild
+++ b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Grub menu entries for the .iso image of systemrescuecd-x86"
HOMEPAGE="http://www.sysresccd.org/"
@@ -10,7 +10,6 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE=""
S=${WORKDIR}