summaryrefslogtreecommitdiff
path: root/sys-boot/syslinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sys-boot/syslinux
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/Manifest1
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index 162be9b57138..4c83fdecb7ac 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -8,5 +8,6 @@ DIST syslinux-6.04-pre1.tar.xz 5283272 BLAKE2B 800e5977ed13b26a1756c33d8625e8506
EBUILD syslinux-5.10.ebuild 2230 BLAKE2B 995ee83ea6a912f0af1ca97e4a960e569c385118e9f234f4f6421d7ab7f409e49c3c4b5fb6bafd6264bfe39c1318f49b142bba809a0dba378ebcef395c2a0809 SHA512 7d61dd6de70b5cd11754b81777bfcdb63c116ad5c772aa9e907bcf6bfe8d918afae8797dae362c888d4d16845fbe1d2077ac7c374f8bbe1f7c5069d2d570c0bb
EBUILD syslinux-6.03.ebuild 3421 BLAKE2B 253a2b38846a07d3bdda05536c2d570e393b9182352e4e936f3213346fb8b0ee5573e5df2bb67bbc692dc5c52569ad3a667a19c14eb58ca7ec1e79ee46e67298 SHA512 041fa544ef45df4732597993c19448728ae6272a87306ff40cdb72e2dc3de5a7b54feb88f27a2660a2aa6932cb47682b42996bab618586bfdf608a959a1d1330
EBUILD syslinux-6.04_pre1-r1.ebuild 3157 BLAKE2B ab29ee00207cfe57bc11e7ed28a953f9a3fb1c8d38de1c0590b744d9b72b8faf4b1fcaab0a3f5b8e88cc23410ec02533b47da4d74a70a6df78c2a48e75fc959d SHA512 3a3bee229af67282a2967dbbc64238bc3c747d31e091843b0f67a878a5145aebeb3dbf99c7600496112d2af6c1fa2b8180f037b2facc6be0dedf65296e89000b
+EBUILD syslinux-6.04_pre1-r2.ebuild 3217 BLAKE2B 15b770ce608e6644033d014970a92f693502cd6d9567fa719b05f47ae7deb7e245f69059c5217639b7eae807ab904d69f9a0c6dc9412b9f8c3ec535f966c638b SHA512 330fc00b75f935146c0b34756c22dbab07dfbe8eaf5a85c2df98a9611141baf8d4bf6ef0fa6084c21568cd2ece750fc94afd56e2d00e0388a0150049aa3e540a
EBUILD syslinux-6.04_pre1.ebuild 3489 BLAKE2B 78481eb4d56f6670a9e3dd6fb8a1b4abfc8cdf67ab3d549c16e88f6cc8a908c4ace33d04e857ea40b7990a1e06d9fa04573077a876634fa77d3f00bd35b3fa12 SHA512 3d628c258a6671c4977d98e575d05d88101451f2d962433eec373777921773658460fba7e7f992d1857ae5a28f64faa02b6bed8bdd5bac8a65311b8e009aaffe
MISC metadata.xml 411 BLAKE2B d3b00622fd68d6ae1b4ba7aa30c33c790b2fbdc688637d3c573cb4496f3952a62f8ae20384badda70b9cbd4ed036e0884becd212d63ec015decc511f1ee7970e SHA512 e8256115d61eeef51be14bea35df6765b356471d145ad8e43e75e6301a4557d526af5fd99b8957fb02ecd9c4a7a0bd0d3db4790abef935887bff8a102709c518
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
new file mode 100644
index 000000000000..415672bbf778
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
+HOMEPAGE="https://www.syslinux.org/"
+# Final releases in 6.xx/$PV.tar.* (literal "xx")
+# Testing releases in Testing/$PV/$PV.tar.*
+SRC_URI_DIR=${PV:0:1}.xx
+SRC_URI_TESTING=Testing/${PV:0:4}
+[[ ${PV/_alpha} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
+[[ ${PV/_beta} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
+[[ ${PV/_pre} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
+[[ ${PV/_rc} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
+SRC_URI="https://www.kernel.org/pub/linux/utils/boot/syslinux/${SRC_URI_DIR}/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="custom-cflags"
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ >=sys-boot/gnu-efi-3.0u
+ virtual/os-headers"
+
+S=${WORKDIR}/${P/_/-}
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# These are executables which come precompiled and are run by the boot loader
+QA_PREBUILT="usr/share/${PN}/*.c32"
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.03-sysmacros.patch #579928
+ "${FILESDIR}"/${P}-singleloadsegment.patch #662678
+ "${FILESDIR}"/${P}-fcommon.patch #705730
+)
+
+src_prepare() {
+ default
+
+ rm -f gethostip #bug 137081
+
+ # Don't prestrip or override user LDFLAGS, bug #305783
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
+ fi
+ case ${ARCH} in
+ amd64) loaderarch="efi64" ;;
+ x86) loaderarch="efi32" ;;
+ *) ewarn "Unsupported architecture, building installers only." ;;
+ esac
+
+ # building with ld.gold causes problems, bug #563364
+ if tc-ld-is-gold; then
+ ewarn "Building syslinux with the gold linker may cause problems, see bug #563364"
+ if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
+ tc-ld-disable-gold
+ ewarn "set I_KNOW_WHAT_I_AM_DOING=1 to override this."
+ else
+ ewarn "Continuing anyway as requested."
+ fi
+ fi
+
+ tc-export AR CC LD OBJCOPY RANLIB
+}
+
+_emake() {
+ emake \
+ AR="${AR}" \
+ CC="${CC}" \
+ LD="${LD}" \
+ OBJCOPY="${OBJCOPY}" \
+ RANLIB="${RANLIB}" \
+ "$@"
+}
+
+src_compile() {
+ # build system abuses the LDFLAGS variable to pass arguments to ld
+ unset LDFLAGS
+ if [[ ! -z ${loaderarch} ]]; then
+ _emake ${loaderarch}
+ fi
+ _emake ${loaderarch} installer
+}
+
+src_install() {
+ # parallel install fails sometimes
+ einfo "loaderarch=${loaderarch}"
+ _emake -j1 INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
+ dodoc README NEWS doc/*.txt
+}