summaryrefslogtreecommitdiff
path: root/sys-boot/syslinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sys-boot/syslinux
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/Manifest1
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index b861a14cf309..fb8c1766ea60 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -3,5 +3,4 @@ AUX syslinux-6.04_pre1-fcommon.patch 2111 BLAKE2B 6b0d047cc729e7e9c9658ccd6ecd11
AUX syslinux-6.04_pre1-singleloadsegment.patch 4744 BLAKE2B a28ff29b9a4bdd2cb65a6700c96ff99ba1a045a401d50587efe59d703f12aca3e47a14a8e7a569c50f11d367545990d09c35f90362efe49d0c9d489802885879 SHA512 9585edfc8ab0e22d4d7757ccdc435c198c5457466fb4fdefc1829cbbe8951f3406b7b51eea56044cc297d29e45772e2154e5746e6d9b92310f17c880c950ff8a
DIST syslinux-6.04-pre1.tar.xz 5283272 BLAKE2B 800e5977ed13b26a1756c33d8625e850631b642e26a86e3328196ddd998596693c3a26db0ada4c0ba78a4ba692a1cc01886b6eb693d877ddafcfb325ecdeb639 SHA512 7927dd39be8e2dcf4138a6fea33def67d19d938379d694f15b48fdd2f5924c028b7a9e7bd71d0c7c6630c203e9e2a54296628e530632ad5e6f55b1ebefe8fc98
EBUILD syslinux-6.04_pre1-r2.ebuild 3215 BLAKE2B d58ca87c5028617f4a08e09b94a53a07e56b8f9c9dcef9fdce21d4d5e7b5d907dd59c63f1e2ee654336b5b20af1aa549eca05c3bc86a07cceda67f9f155c8aa5 SHA512 b8bb532a2ecd2d01ca1130535a54dd9e47e4fd98ebfe00f5a087712fde855d3012bdde3a1009fde5f073319b34a464c5a671718f3cf37b6f29642aed1a7482dd
-EBUILD syslinux-6.04_pre1.ebuild 3489 BLAKE2B 78481eb4d56f6670a9e3dd6fb8a1b4abfc8cdf67ab3d549c16e88f6cc8a908c4ace33d04e857ea40b7990a1e06d9fa04573077a876634fa77d3f00bd35b3fa12 SHA512 3d628c258a6671c4977d98e575d05d88101451f2d962433eec373777921773658460fba7e7f992d1857ae5a28f64faa02b6bed8bdd5bac8a65311b8e009aaffe
MISC metadata.xml 411 BLAKE2B d3b00622fd68d6ae1b4ba7aa30c33c790b2fbdc688637d3c573cb4496f3952a62f8ae20384badda70b9cbd4ed036e0884becd212d63ec015decc511f1ee7970e SHA512 e8256115d61eeef51be14bea35df6765b356471d145ad8e43e75e6301a4557d526af5fd99b8957fb02ecd9c4a7a0bd0d3db4790abef935887bff8a102709c518
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1.ebuild
deleted file mode 100644
index 3fb6b3a94cc3..000000000000
--- a/sys-boot/syslinux/syslinux-6.04_pre1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
-HOMEPAGE="https://www.syslinux.org/"
-# Final releases in 6.xx/$PV.tar.* (literal "xx")
-# Testing releases in Testing/$PV/$PV.tar.*
-SRC_URI_DIR=${PV:0:1}.xx
-SRC_URI_TESTING=Testing/${PV:0:4}
-[[ ${PV/_alpha} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_beta} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_pre} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-[[ ${PV/_rc} != $PV ]] && SRC_URI_DIR=$SRC_URI_TESTING
-SRC_URI="https://www.kernel.org/pub/linux/utils/boot/syslinux/${SRC_URI_DIR}/${P/_/-}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="custom-cflags"
-
-RDEPEND="sys-fs/mtools
- dev-perl/Crypt-PasswdMD5
- dev-perl/Digest-SHA1"
-DEPEND="${RDEPEND}
- dev-lang/nasm
- >=sys-boot/gnu-efi-3.0u
- virtual/os-headers"
-
-S=${WORKDIR}/${P/_/-}
-
-# This ebuild is a departure from the old way of rebuilding everything in syslinux
-# This departure is necessary since hpa doesn't support the rebuilding of anything other
-# than the installers.
-
-# These are executables which come precompiled and are run by the boot loader
-QA_PREBUILT="usr/share/${PN}/*.c32"
-
-# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
-
-src_prepare() {
- rm -f gethostip #bug 137081
-
- epatch "${FILESDIR}"/${PN}-6.03-sysmacros.patch #579928
- epatch "${FILESDIR}"/${P}-singleloadsegment.patch #662678
-
- # Don't prestrip or override user LDFLAGS, bug #305783
- local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
- sample/Makefile utils/Makefile"
- sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
-
- if use custom-cflags; then
- sed -i ${SYSLINUX_MAKEFILES} \
- -e 's|-g -Os||g' \
- -e 's|-Os||g' \
- -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
- || die "sed custom-cflags failed"
- else
- QA_FLAGS_IGNORED="
- /sbin/extlinux
- /usr/bin/memdiskfind
- /usr/bin/gethostip
- /usr/bin/isohybrid
- /usr/bin/syslinux
- "
- fi
- case ${ARCH} in
- amd64) loaderarch="efi64" ;;
- x86) loaderarch="efi32" ;;
- *) ewarn "Unsupported architecture, building installers only." ;;
- esac
-
- # building with ld.gold causes problems, bug #563364
- if tc-ld-is-gold; then
- ewarn "Building syslinux with the gold linker may cause problems, see bug #563364"
- if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
- tc-ld-disable-gold
- ewarn "set I_KNOW_WHAT_I_AM_DOING=1 to override this."
- else
- ewarn "Continuing anyway as requested."
- fi
- fi
-
- epatch_user
-}
-
-src_compile() {
- # build system abuses the LDFLAGS variable to pass arguments to ld
- unset LDFLAGS
- if [[ ! -z ${loaderarch} ]]; then
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch}
- fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch} installer
-}
-
-src_install() {
- # parallel install fails sometimes
- einfo "loaderarch=${loaderarch}"
- emake -j1 LD="$(tc-getLD)" INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
- dodoc README NEWS doc/*.txt
-}
-
-pkg_postinst() {
- # print warning for users upgrading from the previous stable version
- if has 4.07 ${REPLACING_VERSIONS}; then
- ewarn "syslinux now uses dynamically linked ELF executables. Before you reboot,"
- ewarn "ensure that needed dependencies are fulfilled. For example, run from your"
- ewarn "syslinux directory:"
- ewarn
- ewarn "LD_LIBRARY_PATH=\".\" ldd menu.c32"
- fi
-}