summaryrefslogtreecommitdiff
path: root/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-boot/sgibootcd/sgibootcd-0.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-boot/sgibootcd/sgibootcd-0.12.ebuild')
-rw-r--r--sys-boot/sgibootcd/sgibootcd-0.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-boot/sgibootcd/sgibootcd-0.12.ebuild b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
new file mode 100644
index 000000000000..c2b3c0449c57
--- /dev/null
+++ b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
+HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
+SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+RDEPEND=""
+DEPEND=""
+RESTRICT=""
+
+src_compile() {
+ local mycc="$(tc-getCC) ${CFLAGS}"
+
+ [ -f "${S}/sgibootcd" ] && rm -f "${S}"/sgibootcd
+ einfo "${mycc} sgibootcd.c -o sgibootcd"
+ ${mycc} sgibootcd.c -o sgibootcd
+}
+
+src_install() {
+ dobin "${S}"/sgibootcd
+}