summaryrefslogtreecommitdiff
path: root/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild')
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
new file mode 100644
index 000000000000..cbcd73c52a0c
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/Kangie/plymouth-openrc-plugin"
+SRC_URI="https://github.com/Kangie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/openrc"
+RDEPEND="${DEPEND}
+ sys-boot/plymouth
+ !sys-apps/systemd"
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+ fi
+}