summaryrefslogtreecommitdiff
path: root/sys-boot/palo/palo-2.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 02:37:51 +0100
commitf090ac33320e52dd549b818be0c345a3bb870ae0 (patch)
tree2a93d78a55e094fd70aba050c185671713ca63e2 /sys-boot/palo/palo-2.22.ebuild
parent343082998723d09c7b354eb21ff4793c6d4fda3e (diff)
gentoo auto-resync : 20:08:2022 - 02:37:51
Diffstat (limited to 'sys-boot/palo/palo-2.22.ebuild')
-rw-r--r--sys-boot/palo/palo-2.22.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-2.22.ebuild b/sys-boot/palo/palo-2.22.ebuild
new file mode 100644
index 000000000000..9f304fe83eaf
--- /dev/null
+++ b/sys-boot/palo/palo-2.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}