summaryrefslogtreecommitdiff
path: root/sys-boot/os-prober
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /sys-boot/os-prober
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/Manifest2
-rw-r--r--sys-boot/os-prober/os-prober-1.77.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/sys-boot/os-prober/Manifest b/sys-boot/os-prober/Manifest
index 18350bd4683c..cfa5235127e1 100644
--- a/sys-boot/os-prober/Manifest
+++ b/sys-boot/os-prober/Manifest
@@ -1,4 +1,6 @@
AUX os-prober-1.76-exherbo.patch 905 BLAKE2B e8d78b730d33b5760128eaf910f20ac01dc7db3e2b3a271279859869e3c8451e7c8dd72ed5b2784a0dfbf3f31747a81509445d3793a8ed8070a1a721b1b84186 SHA512 0c3c2e4cde868e186131b08268e6344841f0830be5bf4131e5a7ded93a222097599b0a011168e4b7bd0bc97b69ece194df1d46d98eac2c921f16b3e76d004cc8
DIST os-prober_1.76.tar.xz 26432 BLAKE2B edefc2be0bb51fff3cc0cd582c46a50871228b2c94312e50320e717b9f218854a0682d0b4e66b4bef6455751fcf016fa290ab03923d89acc6965bbc9efcbaafd SHA512 64800c99e0959a35edb639f50d2467453c6f6a7d7fa7a8d74141be36e0ade96ce4f874ba6376adfd663585ce9f47b99038dc00c2f722e6236344047567ed14f3
+DIST os-prober_1.77.tar.xz 26660 BLAKE2B cff8d96927cf251e9d8ee95561289e9c49a89fbcf9045e7c7169f73b1eeb151797db7b075ebc14dbbdd96996d007b07001e2843cf835defd675f63595614297b SHA512 4d9c22ccc4d950644a06a17ec4424aca5ff82aeb20052dc389dd451b6b9a1799c5a9438644a29093153730af42066abbbbb78f593f2564314c9adbd43f60e39b
EBUILD os-prober-1.76-r1.ebuild 1832 BLAKE2B 737543b39bacce8057a777738d15779e7a14dc31b5a5ea570c76df84d9522a30b07c6092b02b9cbf5b24ed78f7f910e700c249a57980361fe7917ae828374707 SHA512 2652a50732c26807c6a8d40ce31e330df06f3e614e51bc8a3145724cb13a0b8ec3fbc2b980f3aaccbf9d68487724a62898fef649e8cdd24605eb283547707de6
+EBUILD os-prober-1.77.ebuild 1853 BLAKE2B 26ad9d135cfd8c5d985b5b8cca0a9233d6d4e24ca12e75ec7b0008ecf047d7e1fd18a539bca73f96dc3cd6d9950fc39ba4e1b0305a5c130374dac28c6f0bc03e SHA512 9d01f82256966e1f3f340ca810e41476adedea3730633516144defc8934acf133a0de60d8dd36f35466ee9240bbb2608cbed05be4c046435d29fbda9fcaba2c1
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/sys-boot/os-prober/os-prober-1.77.ebuild b/sys-boot/os-prober/os-prober-1.77.ebuild
new file mode 100644
index 000000000000..fb76f8f0130a
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.77.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="https://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# grub-mount needed per bug #607518
+RDEPEND="sys-boot/grub:2[mount]"
+DEPEND=""
+
+# bug 594250
+QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.76-exherbo.patch )
+
+DOC_CONTENTS="
+ If you intend for os-prober to detect versions of Windows installed on
+ NTFS-formatted partitions, your system must be capable of reading the
+ NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g
+"
+
+src_prepare() {
+ default
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/${dir}
+ doexe ${dir}/common/*
+ if [[ -d ${dir}/${debarch} ]]; then
+ doexe ${dir}/${debarch}/*
+ fi
+ if [[ -d ${dir}/${debarch}/efi ]]; then
+ exeinto /usr/lib/${dir}/efi
+ doexe ${dir}/${debarch}/efi/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ einstalldocs
+ dodoc debian/changelog
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}