summaryrefslogtreecommitdiff
path: root/sys-boot/mbr-gpt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-boot/mbr-gpt
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-boot/mbr-gpt')
-rw-r--r--sys-boot/mbr-gpt/Manifest2
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild12
2 files changed, 10 insertions, 4 deletions
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
index 9ba97165d495..f592d32a023f 100644
--- a/sys-boot/mbr-gpt/Manifest
+++ b/sys-boot/mbr-gpt/Manifest
@@ -1,3 +1,3 @@
DIST mbr-gpt_0.0.1.tar.gz 15861 BLAKE2B 00c6741fa5543af435cee97132510126d0301db2fb50712d438703165507125b4981844cb4a841b11bad075af5effb746fd3aa04e6834fb051536b250c01f7ad SHA512 eaabd84fc749ddee8fa40632ad49e15e894bf35a881fb7c35ba22796c2459a886e9bda601595e58d29567ff26959ae2befe6aec5db397d15e1dc5a292dafe165
-EBUILD mbr-gpt-0.0.1-r1.ebuild 1732 BLAKE2B 7d70ef486c3ff3ae3f37112df599377e287fa34e463ef0d89935aa6e6a9ef43f824de1b5246b024d0fbffa633b670af6a516cc9675c65e37331899c95aecb441 SHA512 3d84928160657a83270e7ec206d9bfa87d209b3899ab99753115212d9c6e5266ff0dd179432239c2e47422cb6f1c65177d061587957d878a6dbeebbf6e4ee1a7
+EBUILD mbr-gpt-0.0.1-r1.ebuild 1736 BLAKE2B fe763dc6620e620780b5b62b6e18b181de1d1e48611054a5423716fe289b432646e7c436ed5f5404fd1cda569f00ca4b1ab13bd26768cf138ea9e41806f4fefc SHA512 4cd5b1967c376b7209b7168587cfd162dad0be3ef22dbce63717b6aed269401c6a8bfbd8d3053594c8a7c760d94e7db3a69d29282051addfd00dbd6b28749c7e
MISC metadata.xml 665 BLAKE2B ad75295ccf49280adce38241b7d2b09ea5461e9aafaa63f6e33eaa35b4639f91535b9ebd4212e91f832020e38ed8f638e03dc6629c6d74490548866b9d58a497 SHA512 b2b28b150ab2f6a983b82216b6d900e2a2893872092dfb8e2e608899c76e182cd581528311e0135177e60b576bca3f9923bd7eb0e54d9d7a8a434b4c87fa6883
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild
index 294caff68d95..3073a1e1cfed 100644
--- a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild
+++ b/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild
@@ -3,19 +3,20 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An MBR that can handle BIOS-based boot on GPT"
MY_P="${PN}_${PV}"
HOMEPAGE="https://web.archive.org/web/20080704173538/http://aybabtu.com/mbr-gpt/"
SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${MY_P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
# It's also pure ASM, so not suitable for elsewhere anyway.
# Please don't remove it, robbat2 has a box that depends on it for # booting!
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
# It only depends on binutils/gcc/make, and doesn't link against libc even.
DEPEND=""
RDEPEND=""
@@ -30,12 +31,15 @@ RESTRICT="binchecks strip"
src_prepare() {
default
+
# Messy upstream
emake clean
# Need to build it 32-bit for the MBR
# Btw, no CFLAGS are respected, it's ASM!
- use amd64 && sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile
+ if use amd64 ; then
+ sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile || die
+ fi
}
src_compile() {
@@ -47,9 +51,11 @@ src_install() {
# location.
insinto /usr/lib/${PN}
doins mbr
+
exeinto /usr/lib/${PN}
exeopts -m 700
doexe boot.elf
+
dodoc AUTHORS
}