summaryrefslogtreecommitdiff
path: root/sys-boot/elilo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /sys-boot/elilo
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'sys-boot/elilo')
-rw-r--r--sys-boot/elilo/Manifest1
-rw-r--r--sys-boot/elilo/elilo-3.16-r5.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-boot/elilo/Manifest b/sys-boot/elilo/Manifest
index c974f543daa8..443d9226102a 100644
--- a/sys-boot/elilo/Manifest
+++ b/sys-boot/elilo/Manifest
@@ -7,4 +7,5 @@ AUX elilo.conf.sample 150 BLAKE2B d823113e1fcdaf08398f09b6fe9b4b2284004be2886799
DIST elilo-3.16-all.tar.gz 485844 BLAKE2B 813762ffef32a640c074973a07d886e0de137be10ff08e9375cd894b0d83dd8bc96cc33f80da1e698db49cc9f105a905abb2fa04048eaca394d3d70e79cb8534 SHA512 4289b45f2e40b2a12167f2efd9a482cf97baedb13fc24813f360f375296d0d3f107d6c980b4b31262816f664a2536353fa124e689cbd65093da9b16fdddaf842
DIST elilo_3.14-3.debian.tar.gz 32179 BLAKE2B 84f8055d3e33b99ce91079768da80a8800c3c2f569ce5619641a983efb943055dfd9a8fb2fda8e5e6d60009ffefbcc1573098f022f06635d4d5304bc3bfddf1e SHA512 b2d5927bf84d61cc432fc916301ddb3be74db16d3e5ba4f13039e2925606b8870991fbb17f837005d8f2b655b7dcd2b2311dfacd7f02183762caf7081ede638f
EBUILD elilo-3.16-r4.ebuild 2277 BLAKE2B 7b29d8511271cf92005dcc7a936c599843c8988182f7261edfa2afb6231918110bc13f2abb5c232d1c1b03f76d45dc364c31d80654eaef45571c1e78c031f094 SHA512 fd87496911f805e11ddb83ea44bc246812329bc236582c2d9ba2ac48ef50b4bcaad84b2db34f0628d35282df141f0ad95028a93b4103b550d6412d07a51c3c58
+EBUILD elilo-3.16-r5.ebuild 2268 BLAKE2B 2f0863a55a5fa846a8f81afcefb37b1ed00403985bd7cfa427505b1d52967adf9e6fd554ea4f3ec6fa941d22e59a9214e2bd4104238d37474f72f6a6a4c7563a SHA512 7d33c42bba010f6bee117e2349459d7b376b034961f430470906d13288a89ad17f5fbbd04bb0462330b6fec7893594f5f3fc7c3811132988fce9b6c4c037bab4
MISC metadata.xml 326 BLAKE2B cc7b85b290136d54ab8857ad992bef9eca8cbb607949a50ff090ddfbbab704d87d3e028415845fddc57ea984215dfe0048d1a219dcd386dcf1c1062f657f5db8 SHA512 e40b5a31e5e5954c817f994c6215488a34b32191cfc597e5514bef2fa1ae1e36f0aca1b7e80043e452946051885a04081875edd53d285fc557cbe3277ae3d624
diff --git a/sys-boot/elilo/elilo-3.16-r5.ebuild b/sys-boot/elilo/elilo-3.16-r5.ebuild
new file mode 100644
index 000000000000..fed811421390
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.16-r5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="https://sourceforge.net/projects/elilo/"
+SRC_URI="mirror://sourceforge/elilo/${P}-all.tar.gz
+ mirror://debian/pool/main/e/elilo/elilo_3.14-3.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ dev-util/patchutils"
+# dosfstools[compat] to enable 'dosfsck' symlink
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools[compat]"
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.16-elilo-loop.patch #299665
+ "${FILESDIR}"/${PN}-3.16-gnu-efi-3.0.6-ia64.patch
+ "${FILESDIR}"/${PN}-3.16-strncpy-clash.patch
+ "${FILESDIR}"/${PN}-3.16-FLAGS.patch
+ "${FILESDIR}"/${PN}-3.16-ARCH.patch
+)
+
+src_unpack() {
+ unpack ${A} ./${P}-source.tar.gz
+ mv debian "${S}"/ || die
+}
+
+src_prepare() {
+ default
+
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # Now Gentooize it.
+ sed -i \
+ -e '1s:/bin/sh:/bin/bash:' \
+ -e "s:##VERSION##:${PV}:" \
+ -e 's:Debian GNU/:Gentoo :g' \
+ -e 's:Debian:Gentoo:g' \
+ -e 's:debian:gentoo:g' \
+ -e "s:dpkg --print-architecture:echo ${iarch}:" \
+ debian/elilo.sh || die
+}
+
+src_compile() {
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ local libdir="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ emake -j1 \
+ prefix= \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ HOSTARCH=${iarch} \
+ ARCH=${iarch} \
+ EFIINC="${SYSROOT}${EPREFIX}/usr/include/efi" \
+ GNUEFILIB="${libdir}" \
+ EFILIB="${libdir}" \
+ EFICRT0="${libdir}" \
+ NATIVE_CFLAGS="${CFLAGS}" \
+ NATIVE_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi
+
+ newsbin debian/elilo.sh elilo
+ dosbin tools/eliloalt
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}