summaryrefslogtreecommitdiff
path: root/sys-boot/elilo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /sys-boot/elilo
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'sys-boot/elilo')
-rw-r--r--sys-boot/elilo/Manifest1
-rw-r--r--sys-boot/elilo/elilo-3.16-r1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/sys-boot/elilo/Manifest b/sys-boot/elilo/Manifest
index a1be1215101f..c992abd5fc68 100644
--- a/sys-boot/elilo/Manifest
+++ b/sys-boot/elilo/Manifest
@@ -12,6 +12,7 @@ DIST elilo_3.14-3.debian.tar.gz 32179 BLAKE2B 84f8055d3e33b99ce91079768da80a8800
DIST elilo_3.6-1.diff.gz 14944 BLAKE2B c982bce4610168408c57beaeca70f7c2be130a75e29b662f5d21ab22097374cc2c8152f24a6eef73039fd6eb365d66c3d4d63f52fe021bb5b126f1932efdaec3 SHA512 962672f516de48f88bd453248d6469a4962fb7551214de9f73125deb64121ab08d123746b2cf8c1c202177f7272aad4cb63e6970f1860c772930bae580817bee
EBUILD elilo-3.10.ebuild 1881 BLAKE2B c4fc100d3f8cf5a91a577a84aa96f0e015c006cf45bfe8d979c95dec896c11862e2d8280490fa77e7cb2ed3dc078bec6f02a058c8d13bff79529526fb6c0f4c6 SHA512 40c43228a756ed0ffe1b6ee0e7ca1a15dd4eeae4ef11533e7604f1f9bc25a3395048721403abb84bf1bbe97652da0d8b2992e80698e49e0135f8f2e3804f40c6
EBUILD elilo-3.12.ebuild 1875 BLAKE2B e3bf5b05fa281d2ecc388b3b94143f196a780bd4bc9f156055959a9076a71fe4f9b909bf212ce225b1c616883b1c127a24f5e3140d30d2c89e32f42c6f970eec SHA512 e1133533b8727e744457086550771ead877279a919676006562d38e0a6e2949f2d95eb828d1664b3f726d072a83b184ea32632785df92d20b9f5d09cb0914c57
+EBUILD elilo-3.16-r1.ebuild 2022 BLAKE2B 2b7e34a158bbb348c1468d1e79bfccf885f8479f0d209a36e1f9fff334d52fb5eadbb98082ad75b44e5cae50bc2909fb710aab42fee9f54a7c9e73be7e7faa9f SHA512 428ff3638702d11ff93a19c6b3aeca9c9dab556773a6b6a6b3632ed240ae64a3c6269e48f1466dbaf58ebc23c2eb340cbd98c50b0f7a5b45c3224a17b7ed4110
EBUILD elilo-3.16.ebuild 2032 BLAKE2B 12c7a08970bcb568944607fb6f9066d6b4bd19dda8a956f0f98480ddae577dab1cba0566b39c4214fd50b618c6df6d797957cafa7f40ccc1d70540dd7d642f3b SHA512 3eefb2956ce6cd1f5322c7ef537fb04fb9518ffb294361c0a449154adf11729ec7999167754cd034cfcbadb16616324c6866f8356e72e73e4aaf52a4e4f77398
EBUILD elilo-3.6_p20060314.ebuild 2290 BLAKE2B b47fe3063eb438f8dcf7ce47b500ecd4fcc8e79bd5f560e052c5662d127fdc640d68cb20e06250b8286285f97fac04331ad52d66e588b3baeaa2790b2464ede1 SHA512 4eb9e60abbec84dbe1a65138feb2ff0411faf54144549a4bff521aa867833cb211457589bc457cac072061714197b77abaf4267e3f21b6af591878114dd1b5ff
MISC metadata.xml 337 BLAKE2B 7c9b3e56e9680252631db0691b3acfc2a2cbfee80c42af709979085124a35bb9d184e58de3ef4f88b2f3e6cc873b4ef2bd285ce3fc2645aaa9ae869c3b729d87 SHA512 13691bef927bf7f8a4a6d0640d38dabb53fdae1d8bd986c5fe73c1643e2bdbaaac50bfe864e2185a584fa6265a3197afc5273b60b70675481cef61706dde8d87
diff --git a/sys-boot/elilo/elilo-3.16-r1.ebuild b/sys-boot/elilo/elilo-3.16-r1.ebuild
new file mode 100644
index 000000000000..96b2860daf60
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.16-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="https://sourceforge.net/projects/elilo/"
+SRC_URI="mirror://sourceforge/elilo/${P}-all.tar.gz
+ mirror://debian/pool/main/e/elilo/elilo_3.14-3.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ dev-util/patchutils"
+# dosfstools[compat] to enable 'dosfsck' symlink
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools[compat]"
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.16-elilo-loop.patch #299665
+)
+
+src_unpack() {
+ unpack ${A} ./${P}-source.tar.gz
+ mv debian "${S}"/ || die
+}
+
+src_prepare() {
+ default
+
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # Now Gentooize it.
+ sed -i \
+ -e '1s:/bin/sh:/bin/bash:' \
+ -e "s:##VERSION##:${PV}:" \
+ -e 's:Debian GNU/:Gentoo :g' \
+ -e 's:Debian:Gentoo:g' \
+ -e 's:debian:gentoo:g' \
+ -e "s:dpkg --print-architecture:echo ${iarch}:" \
+ debian/elilo.sh || die
+}
+
+src_compile() {
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ local libdir="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ emake -j1 \
+ prefix= \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ HOSTARCH=${iarch} \
+ ARCH=${iarch} \
+ EFIINC="${SYSROOT}${EPREFIX}/usr/include/efi" \
+ GNUEFILIB="${libdir}" \
+ EFILIB="${libdir}" \
+ EFICRT0="${libdir}"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi
+
+ newsbin debian/elilo.sh elilo
+ dosbin tools/eliloalt
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}