summaryrefslogtreecommitdiff
path: root/sys-boot/bootcreator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-boot/bootcreator
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-boot/bootcreator')
-rw-r--r--sys-boot/bootcreator/Manifest6
-rw-r--r--sys-boot/bootcreator/bootcreator-1.1.ebuild29
-rw-r--r--sys-boot/bootcreator/bootcreator-1.2.ebuild29
-rw-r--r--sys-boot/bootcreator/metadata.xml8
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-boot/bootcreator/Manifest b/sys-boot/bootcreator/Manifest
new file mode 100644
index 000000000000..89aa735c7718
--- /dev/null
+++ b/sys-boot/bootcreator/Manifest
@@ -0,0 +1,6 @@
+DIST bootcreator-src.tar.gz 18881 SHA256 d1a1b581b65c468415867d005916cb898fc11788660819568434245cc162e3cb SHA512 53a17cc6b6ec9eea06b4162f32068d5f6c86ff066cc152e30c346010b197a88f3266315295c90b7123a68e81fb4ee95e4b0b341ef666df2eaa230ac762892d0e WHIRLPOOL 070f84fd33e5dcaad21d922a69a5b632f3882b6cd3fe90b046aa11f608536b662bb6869a30c9c8e5ceeb04db67aaf6e041f29912fcbaac4b4156aad6bbdad2e9
+EBUILD bootcreator-1.1.ebuild 557 SHA256 efcf4febeabb24c5d9e79852f183ad4cc9462d48ba8da8f1fba4e087e84c16dd SHA512 1417c14f8245ce28a96e04ef4c18a1d84edb661fc45ebc3820da75fc579f12825702058ce8fe3dce2c6af18982693f6d3eec0a81043b2cb5fae26af29e9f76b6 WHIRLPOOL 712ea5259d33b3d44019ad8e870d88035bb4e16c04c66dc7b86ca3845cf41936cfc6f4e694fe6baa606d1c4b200227260414925554192a898ab892878b452a3d
+EBUILD bootcreator-1.2.ebuild 557 SHA256 efcf4febeabb24c5d9e79852f183ad4cc9462d48ba8da8f1fba4e087e84c16dd SHA512 1417c14f8245ce28a96e04ef4c18a1d84edb661fc45ebc3820da75fc579f12825702058ce8fe3dce2c6af18982693f6d3eec0a81043b2cb5fae26af29e9f76b6 WHIRLPOOL 712ea5259d33b3d44019ad8e870d88035bb4e16c04c66dc7b86ca3845cf41936cfc6f4e694fe6baa606d1c4b200227260414925554192a898ab892878b452a3d
+MISC ChangeLog 2491 SHA256 0ab75f7bd47a25bf630e357c47e7f45cf54b892ca71b975b698ae8f7546371f4 SHA512 8a1c1dc7841432177a46c458417a6afdeb5017f08520c4b6f20d5fffd3fa2a4c8f24b5dd3947ad8c975be8b5b9f1b66f8453fe871c38968e5430619be2eaec40 WHIRLPOOL 7a6d3fb5f8cd7a9f5595aae32c469c67b8f33314d425f571f7c2d25bc8afa635087eca3fc92af1f8b1dfe7af47d231b53b09956339e3846da35f0ba0fe7f94d2
+MISC ChangeLog-2015 1160 SHA256 f235cfb05cf4757defcbbc4661b6a50a2bcbf80da6e74615b662e0837ad907c7 SHA512 e5590cf371eea1a64db2c4d62a01a7b1925095e4c2c8b6c4311d2cb13eafcba911ee703c09edbc649b318608b7ba3be4ac9f2cfd5921d2f44e8f6c6c5059fff0 WHIRLPOOL 3906e3f0a6a750fc47ca2b1a0ebc1f14af94a710ed1a8d23d70079559dadc00a909d106421b0f042584466ca8822a3407aa9b131c386972e35da2f762545ce98
+MISC metadata.xml 263 SHA256 bc3ed66da9a359018966a0a199721a238e033433a289439c60668e6f3802f874 SHA512 f72954ee8887da0e1b3e59effb6eb40294102e91b1060c2d736fa47a3a12513d959b44e77fc62f881408e38d30a47f1c5b1c4a0d9c3646b5fb75118e5295ea5d WHIRLPOOL f8c00193f85a48eb02651a6baeff8bab0acd7878475cd28ff9e29858bd10979f95d441318e34f5917687f45e2aa0533d5ab2083b5d2bb2b87df414de5567ad11
diff --git a/sys-boot/bootcreator/bootcreator-1.1.ebuild b/sys-boot/bootcreator/bootcreator-1.1.ebuild
new file mode 100644
index 000000000000..6c39fd7daa63
--- /dev/null
+++ b/sys-boot/bootcreator/bootcreator-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
+HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
+SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -*"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dosbin src/bootcreator
+ dodoc doc/README
+
+ insinto /etc
+ newins examples/example.bc bootmenu.example
+}
diff --git a/sys-boot/bootcreator/bootcreator-1.2.ebuild b/sys-boot/bootcreator/bootcreator-1.2.ebuild
new file mode 100644
index 000000000000..6c39fd7daa63
--- /dev/null
+++ b/sys-boot/bootcreator/bootcreator-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
+HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
+SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -*"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dosbin src/bootcreator
+ dodoc doc/README
+
+ insinto /etc
+ newins examples/example.bc bootmenu.example
+}
diff --git a/sys-boot/bootcreator/metadata.xml b/sys-boot/bootcreator/metadata.xml
new file mode 100644
index 000000000000..0d70baf208e1
--- /dev/null
+++ b/sys-boot/bootcreator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ppc@gentoo.org</email>
+ <name>Gentoo Linux PowerPC Development</name>
+ </maintainer>
+</pkgmetadata>