summaryrefslogtreecommitdiff
path: root/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild')
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
index d6c38443b2c4..cba6251a37af 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
@@ -30,18 +30,20 @@ src_unpack() {
cd "${S}"/include
ln -s asm-alpha asm || die
touch linux/config.h || die
- cd "${S}"
- epatch "${FILESDIR}/aboot-gcc-3.4.patch"
- epatch "${FILESDIR}/aboot-pt_note.patch"
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/aboot-gcc-3.4.patch"
+ eapply "${FILESDIR}/aboot-pt_note.patch"
# Bug 364697
- epatch "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
- epatch "${FILESDIR}"/aboot-respect-AR.patch
- epatch "${FILESDIR}"/aboot-gnu90.patch
+ eapply "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
+ eapply "${FILESDIR}"/aboot-respect-AR.patch
+ eapply "${FILESDIR}"/aboot-gnu90.patch
# Modified patch from Debian to add netboot support
- epatch "${WORKDIR}"/aboot_gentoo.diff
+ eapply "${WORKDIR}"/aboot_gentoo.diff
- epatch_user
+ eapply_user
}
src_compile() {