summaryrefslogtreecommitdiff
path: root/sys-block/whdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
commit236e75597883501f8700d9ba1a5c8276f578a17f (patch)
tree6b441a1dfa3a82840e3aa74678cc90c5294a4bca /sys-block/whdd
parentbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (diff)
gentoo auto-resync : 22:05:2024 - 00:06:25HEADmaster
Diffstat (limited to 'sys-block/whdd')
-rw-r--r--sys-block/whdd/Manifest2
-rw-r--r--sys-block/whdd/whdd-3.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
index eea29a61c952..6d7f0794fea6 100644
--- a/sys-block/whdd/Manifest
+++ b/sys-block/whdd/Manifest
@@ -1,3 +1,5 @@
DIST whdd-3.0.1-rel.tar.gz 45657 BLAKE2B 9730e61580359c95fc3e3d23540f3b10e75b476e634cce3be744b8849193f43f968f227bdbd25a0c643106c1343b27070c8b51f33278e902ab54991a05eee021 SHA512 6d5d8dad7537118a5915a29a549e18595da1b6ba031f0ca661805ad0033fd48f32804eb307f67e7b31d6002e708ae578a32aff366f3e610ab36b25f0a4e50803
+DIST whdd-3.1-rel.tar.gz 45806 BLAKE2B dce0230955fda721539891f0e993f25d3777e7d11331bbbd7b7e853dafd2edba043fc598c672634cc8bb65bad5c0ae9f3e26713f98c0d551dc72d08de20e1eb4 SHA512 8960b482d7c3a75b0b9e540092a0c074dbb66561f455fdf454e8cd89cc5dc4dc028e60b44ce74ecbf568af5e7e34a5b3b5deaee9480112f4161d98b773442bed
EBUILD whdd-3.0.1-r2.ebuild 692 BLAKE2B b8cac90dfb0e6578cdceb3df5e55133c6a0eba4cd598ba1adedc350f1b10ff724c38b4939c144ea06f0c36717b9fb4e617e41d5fbb6d64204985f884f50669d0 SHA512 22b26e2b994f64c4fd66c17835e5b1951db071a088dd149d8a83dd4b1ad6a826419bbccebb1ae4618d2c0c1b29d1d5fd80d1c63052193e13442774ead687cfee
+EBUILD whdd-3.1.ebuild 693 BLAKE2B c65fa343e57b199e88257dc0c7afdfaf328518a9da5225459ce85056738ac168c3239567128331230c38172fc7a589eb90e1bd76fcd6e410c87eb859e2ed8a8a SHA512 8e89e817cc4cd021d2e815bd756598d66eccbbc6fe0065804cbe4da86ca2fff57daccce7f16c3377f373e64d3889e9c6d2809f61ff21a2eb065af7d449f5545e
MISC metadata.xml 320 BLAKE2B 45eeb9de5a78b1f044939348f2fb7e0befb2a3fe2aa66da3dbe30c122c64c105142ba44bfec78e2d760b5a8a185698dc5389bb8f3d9f644dd5c0ee686bd882ec SHA512 ecefce54584273fc6fc699534fc671aa361542c72f0525e779da25180b843b9ee6eb42f467097c3d06b7da200575ac9bdc2c8e1af26e02a6b89f6e7c40a65a16
diff --git a/sys-block/whdd/whdd-3.1.ebuild b/sys-block/whdd/whdd-3.1.ebuild
new file mode 100644
index 000000000000..5009455fad36
--- /dev/null
+++ b/sys-block/whdd/whdd-3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/dialog:=
+ sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}