summaryrefslogtreecommitdiff
path: root/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild
new file mode 100644
index 000000000000..b5191e416491
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.62[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sys-block/targetcli"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=( "${FILESDIR}/${P}-python3.patch" )
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}