summaryrefslogtreecommitdiff
path: root/sys-block/scsiping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /sys-block/scsiping
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'sys-block/scsiping')
-rw-r--r--sys-block/scsiping/Manifest1
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/scsiping/Manifest b/sys-block/scsiping/Manifest
index d49815bca82b..5cfdec799853 100644
--- a/sys-block/scsiping/Manifest
+++ b/sys-block/scsiping/Manifest
@@ -1,3 +1,4 @@
DIST scsiping-0.0.1.tgz 1633 BLAKE2B 81c59f3179e3108aca99f5526f27784c74e9e4a88f27cac316c68a31d979ff43acbc1d1f4733aa918b648f897fe2c211b873c69349a9c3ad63e4ab33219127cf SHA512 ba296f259399c61abecb72793753982ec8effd3ee3c7a1445f10449956b1d42443c989890f8a37e88db4d6bd12eae826b236cd84650cd19ea99602a13dcd9f20
+EBUILD scsiping-0.0.1-r1.ebuild 664 BLAKE2B 6026271e76a2ae9de44baa18e017e598af3625036db4460616061f39ebed176c0648e15e746213ca95686840e4916e797a4ee2b9ff77cc7e90173316400f5f8c SHA512 64bdaf992aa6ee0bf16617fb8d8c646b2f27836a4508c12499065c33468ee852f4e5f8c4b4b4dbb74f1e1a0d4526591724c5a0ead2d2a10a83bddb282563831e
EBUILD scsiping-0.0.1.ebuild 642 BLAKE2B 30f7b6e7d026e73b6527b3aef16aefde0041838a48a3e5dbc02872633ee70e1bc4b940d12e86d25a588452fe332da7c8f980dc046066a0883b2fdab42e2814a1 SHA512 b4bdcbec5bc50b1dc1a481bb825f768321654108014c262b6de67e63a1ac76f7c84246ef42a2f56cab5c14cbf0df8857713799a51cf923bf08bc562497353d7e
MISC metadata.xml 216 BLAKE2B 20531789dc11e43feee7ec315a0c1c7249fdf73764e29cb7d6db439826e9ff72f24a5cdb8eb7f1ab99bbb41fb6e4226874a1d1fa4185de52598602bb3b0479a3 SHA512 e881b59fe49746eb25ad66c258b41aba501e4eb563129093a3898ea970a20506e7898f7c355cfcf99605234962bf2c77c1309c258b9a2b84ee4302ccb71c9dbd
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..4879d3b7f737
--- /dev/null
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="https://www.vanheusden.com/Linux/"
+SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/strip scsiping/d' "${S}"/Makefile
+ default
+}
+
+src_compile() {
+ emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin scsiping
+}
+
+pkg_postinst() {
+ ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}