summaryrefslogtreecommitdiff
path: root/sys-block/scsiadd/scsiadd-1.97.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/scsiadd/scsiadd-1.97.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/scsiadd/scsiadd-1.97.ebuild')
-rw-r--r--sys-block/scsiadd/scsiadd-1.97.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/scsiadd/scsiadd-1.97.ebuild b/sys-block/scsiadd/scsiadd-1.97.ebuild
new file mode 100644
index 000000000000..9c8688882342
--- /dev/null
+++ b/sys-block/scsiadd/scsiadd-1.97.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit user toolchain-funcs flag-o-matic
+
+DESCRIPTION="Add and remove SCSI devices from your Linux system during runtime"
+HOMEPAGE="http://llg.cubic.org/tools/"
+SRC_URI="http://llg.cubic.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="suid"
+DEPEND=""
+
+pkg_setup() {
+ use suid && enewgroup scsi
+}
+
+src_prepare() {
+ # remove 'strip' command
+ sed -i -e "s:^\(.*strip.*\):#\1:g" Makefile.in
+
+ # convert docs to utf-8
+ if [ -x "$(type -p iconv)" ]; then
+ for X in NEWS README; do
+ iconv -f LATIN1 -t UTF8 -o "${X}~" "${X}" && mv -f "${X}~" "${X}" || rm -f "${X}~"
+ done
+ fi
+}
+
+src_compile() {
+ # extra safety for suid
+ append-ldflags -Wl,-z,now
+
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dosbin scsiadd || die "install failed"
+ if use suid; then
+ fowners root:scsi /usr/sbin/scsiadd
+ fperms 4710 /usr/sbin/scsiadd
+ fi
+ dodoc NEWS README TODO
+ doman scsiadd.8
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}