summaryrefslogtreecommitdiff
path: root/sys-block/sas3ircu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
commit5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (patch)
treeaa76c2f85f9c77c2f9a5af47ae0aa6509585770a /sys-block/sas3ircu
parent280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (diff)
gentoo auto-resync : 17:08:2023 - 09:31:54
Diffstat (limited to 'sys-block/sas3ircu')
-rw-r--r--sys-block/sas3ircu/Manifest2
-rw-r--r--sys-block/sas3ircu/sas3ircu-16.ebuild7
2 files changed, 7 insertions, 2 deletions
diff --git a/sys-block/sas3ircu/Manifest b/sys-block/sas3ircu/Manifest
index a89cc463a2cc..01c525088322 100644
--- a/sys-block/sas3ircu/Manifest
+++ b/sys-block/sas3ircu/Manifest
@@ -1,4 +1,4 @@
DIST SAS3IRCU_P16.zip 6342932 BLAKE2B a5c4f9a83eb1f51a049e9f04c29c029580590500deb48ae03b0960c394946f1e89d40efc68a0d505004bda519e3174fc573111e95f028c09b1a0ae6bd18f98ed SHA512 cc44d64c500f2608895129414d95cc3d23fae5a3ae39bb28119f150b830ec20b6c934cd1d23dcd1253e9c38ca3b16a7020ae0b8386412638fd2dca6d93d92ac0
DIST SAS3_IR_UG.pdf 714573 BLAKE2B 09a3a47abf6118343f023f4cdf85ab2f5f583f806e305dafa6397d1099fc01ecc33b331afd10d63ac8bb75a365d09c931c19fc673fa707b5171feb23d64f97bf SHA512 4db16dedcadc3daf853e62531ac620af4a3e41d001b58fcd333692f9121d1ca3ec8b9de0113693506b31da714b9368ff55addb0398f2f843e4a6a1bf3d665433
-EBUILD sas3ircu-16.ebuild 2666 BLAKE2B 9dfb536ddd187ba915cf70fb1061990e7554f6eff6a60fb47b7a0fe2c279b595eed938743a50a7eeabf8bac6cbd11265fea7fb83a660db3553b1681c3bfb0487 SHA512 c9ec0594e9c14a8b789729b27a91abdd9209d0d2638c9b2e390eb6f39d88750fd2cf1c2aab7a74a4e66565a627ba083ea4f27e5714824c4b5874b768efacda8e
+EBUILD sas3ircu-16.ebuild 2761 BLAKE2B 32574845fe70a63da52c593baf3d7b9b46a5ab7b4f8f36f1a2cdd92b4ced3530eec095c39dc5a56facf1e20117d1b09d1bdefab44873f735a60eed672c677fa9 SHA512 d8a99c468ee71741b356857af19a32d52b5462abe012196bd3801c5abb0d721ce05358f495154854d7e866ceaa14dd03bd658b9e35460de427ebac535e33ae6a
MISC metadata.xml 313 BLAKE2B bc8103659b1d003c457aa77253ff241c0045ad4b41ddbe3a921af23a43600c6450653189c3ae9c792453bb19c4c9fab7b41adc9228013c6839dba8b1752f63ac SHA512 7dfc67ef64a07f2faf69ec8e5f2050e7b80e30e19da5a261955346a27d78fc12cefac6abd84e15a4b9cb6dbc7439c6114137bc542424c4a75ed83f0635bea090
diff --git a/sys-block/sas3ircu/sas3ircu-16.ebuild b/sys-block/sas3ircu/sas3ircu-16.ebuild
index b9d4c0a25807..bbd2cebcd65b 100644
--- a/sys-block/sas3ircu/sas3ircu-16.ebuild
+++ b/sys-block/sas3ircu/sas3ircu-16.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit mount-boot
+inherit mount-boot secureboot
DESCRIPTION="LSI MPT-SAS3 controller management tool"
HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8e#downloads"
@@ -42,6 +42,10 @@ pkg_nofetch() {
einfo "${SRC_URI}"
}
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
supportedcards() {
elog "This binary supports should support ALL cards, including, but not"
elog "limited to the following series:"
@@ -84,5 +88,6 @@ src_install() {
elif use arm64; then
doexe sas3ircu_rel/sas3ircu/sas3ircu_udk_uefi_arm_rel/sas3ircu.efi
fi
+ secureboot_auto_sign --in-place
fi
}