summaryrefslogtreecommitdiff
path: root/sys-block/parted/parted-3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-block/parted/parted-3.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-block/parted/parted-3.4.ebuild')
-rw-r--r--sys-block/parted/parted-3.4.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/sys-block/parted/parted-3.4.ebuild b/sys-block/parted/parted-3.4.ebuild
deleted file mode 100644
index 338886d0c62d..000000000000
--- a/sys-block/parted/parted-3.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit verify-sig
-
-DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
-HOMEPAGE="https://www.gnu.org/software/parted/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+debug device-mapper nls readline"
-
-# util-linux for libuuid
-RDEPEND="
- >=sys-fs/e2fsprogs-1.27
- sys-apps/util-linux
- device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? (
- >=sys-libs/ncurses-5.7-r7:0=
- >=sys-libs/readline-5.2:0=
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( >=sys-devel/gettext-0.12.1-r2 )
- verify-sig? ( sec-keys/openpgp-keys-bcl )
- virtual/pkgconfig
-"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/bcl.asc
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
- "${FILESDIR}"/${PN}-3.3-atari.patch
- # https://lists.gnu.org/archive/html/bug-parted/2022-02/msg00000.html
- "${FILESDIR}"/${P}-posix-printf.patch
-)
-
-src_prepare() {
- default
- touch doc/pt_BR/Makefile.in || die
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug)
- $(use_enable device-mapper)
- $(use_enable nls)
- $(use_with readline)
- --disable-rpath
- --disable-static
- )
- econf "${myconf[@]}"
-}
-
-DOCS=(
- AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
-)
-
-src_install() {
- default
- find "${ED}" -type f -name '*.la' -delete || die
-}