summaryrefslogtreecommitdiff
path: root/sys-block/nbd/nbd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 09:36:29 +0100
commit77f1c17f5328e59f3991203c579fbc85df6898a0 (patch)
treea548ffa40d8592c0a65665c44087e6ec27d9280b /sys-block/nbd/nbd-9999.ebuild
parent9ce4c0d3ec7daef46290a34cf0b02ae0d5b4f2f2 (diff)
gentoo auto-resync : 05:06:2023 - 09:36:29
Diffstat (limited to 'sys-block/nbd/nbd-9999.ebuild')
-rw-r--r--sys-block/nbd/nbd-9999.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/sys-block/nbd/nbd-9999.ebuild b/sys-block/nbd/nbd-9999.ebuild
index 72e1b43ee6b1..a0554e3c6d37 100644
--- a/sys-block/nbd/nbd-9999.ebuild
+++ b/sys-block/nbd/nbd-9999.ebuild
@@ -1,37 +1,39 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd
DESCRIPTION="Userland client/server for kernel network block device"
-HOMEPAGE="https://nbd.sourceforge.net/"
-if [[ ${PV} = 9999 ]] ; then
+HOMEPAGE="https://nbd.sourceforge.io/"
+
+if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
else
- SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz
- mirror://sourceforge/nbd/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz"
+ SRC_URI+=" mirror://sourceforge/nbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="debug gnutls netlink zlib"
-BDEPEND="virtual/pkgconfig"
-
RDEPEND="
- >=dev-libs/glib-2.26.0
+ >=dev-libs/glib-2.32.0
gnutls? ( >=net-libs/gnutls-2.12.0 )
netlink? ( >=dev-libs/libnl-3.1 )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/bison"
+BDEPEND="
+ sys-devel/bison
+ virtual/pkgconfig
+"
-if [[ ${PV} = 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
BDEPEND+="
app-text/docbook-sgml-dtd:4.5
app-text/docbook-sgml-utils
@@ -42,7 +44,7 @@ fi
src_prepare() {
default
- if [[ ${PV} = 9999 ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
emake -C man -f mans.mk \
nbd-server.1.sh.in \
nbd-server.5.sh.in \
@@ -58,11 +60,15 @@ src_prepare() {
}
src_configure() {
+ # Needs Bison
+ unset YACC
+
local myeconfargs=(
--enable-lfs
+ # https://github.com/NetworkBlockDevice/nbd/issues/149
+ --disable-gznbd
$(use_enable !debug syslog)
$(use_enable debug)
- $(use_enable zlib gznbd)
$(use_with gnutls)
$(use_with netlink libnl)
)