summaryrefslogtreecommitdiff
path: root/sys-block/nbd/nbd-3.16.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/nbd/nbd-3.16.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/nbd/nbd-3.16.2.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.16.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.16.2.ebuild b/sys-block/nbd/nbd-3.16.2.ebuild
new file mode 100644
index 000000000000..44763beacffe
--- /dev/null
+++ b/sys-block/nbd/nbd-3.16.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug zlib"
+
+# gnutls is an automagic dep.
+RDEPEND="
+ >=dev-libs/glib-2.0
+ >=net-libs/gnutls-2.12.0
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-lfs
+ $(use_enable !debug syslog)
+ $(use_enable debug)
+ $(use_enable zlib gznbd)
+ )
+ econf "${myeconfargs[@]}"
+}