summaryrefslogtreecommitdiff
path: root/sys-block/megamgr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/megamgr
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/megamgr')
-rw-r--r--sys-block/megamgr/Manifest5
-rw-r--r--sys-block/megamgr/megamgr-5.20-r2.ebuild43
-rw-r--r--sys-block/megamgr/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-block/megamgr/Manifest b/sys-block/megamgr/Manifest
new file mode 100644
index 000000000000..ddc8099acb44
--- /dev/null
+++ b/sys-block/megamgr/Manifest
@@ -0,0 +1,5 @@
+DIST ut_linux_mgr_5.20.zip 253549 SHA256 e7313ed8f59897f132ffed55ed606f19dc72a5d529e6b647cb157a39f0d79123 SHA512 3f942ab3d7a192bc1a945945d20545ffdbbbdd9c4af238701cf7357fe5b3f405c2e777da7c42908e1acb676499ee87aec261bcad729a4d787f8e098af132bda6 WHIRLPOOL 8efdfa1a152003ab0da0834f101c4da505974ada81eb0633e42d5065b96dcd48638da8145ac1e43573fe0cb25119bf3579a1d778deb18e1258cbca33e1c6cd28
+EBUILD megamgr-5.20-r2.ebuild 1036 SHA256 4f529aaf601bd4be08e2a92aba4b6aca12306f398c91dd08693a682873ea0bd4 SHA512 7994b5e96b40f09819b22c1b134b24e93fe91cbf7d8c4977248751b3f195f7cf5f7a574f208398fe693f35f369dc98ee1fb3247d1f35471fff9091499a39b974 WHIRLPOOL a051e18bf45e86395e5e114eae71b71b8b460ba9647695621f654c7d6c45c874ca66522457f2b0108324ae160a383f151d0bade491a8ca7a3e62d7bc4fcdf591
+MISC ChangeLog 2181 SHA256 da9c63a25f7c0080eebd19ce9654be33a87530d3ebc4d7f919301549f0f146d5 SHA512 00d9c04ad2e72b4ac81f39bd586d5698336109ef71919019b0f874f1a65f668eebe749f563960ad16f9bf7c7803491a5b0d0dad3ce168a7e0d0632b8f4cea76f WHIRLPOOL 64beef6e7eb29a2a8c782eb80b244639f07bd48a874432ba4c68365a57fc612efafb515134ea5808e82c81a3e330fda61565a90a6d9a176e44b9ef361ce0f77e
+MISC ChangeLog-2015 1430 SHA256 da44dc057430e254b7b55b80e1a0636df75d10bd0882c7f74818e0ec7ed54c58 SHA512 dceff1be3f7d9bbb8c70019122a4bc1be9372325ca720f92ad134de14df9a5d5f0fccb189aa4300089a9e6666b14f4f5cf69ae396275c661c9a552854563341b WHIRLPOOL d9afd37ad137f30d27664b9a90fc02672bf5e752ed234cb9d1f95f083f27ed3bd7d39667bf7c129fb695d43487fc366bf880e27b5a31124add271c28e0c7f697
+MISC metadata.xml 167 SHA256 5fe493e76bba84455c54b3a46adfae5a1bfe01c764ef0d9e5f6d3e8a1d142188 SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33 WHIRLPOOL dc6c3dfc7fd7f0d76c97f0786cb76a55b8564f8437f96d4ccebf985817b9f6dcc4c61830aa5df80d725e4a54b281ea2e03d6b0859214af081112cba15025e64b
diff --git a/sys-block/megamgr/megamgr-5.20-r2.ebuild b/sys-block/megamgr/megamgr-5.20-r2.ebuild
new file mode 100644
index 000000000000..d8758416c831
--- /dev/null
+++ b/sys-block/megamgr/megamgr-5.20-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit multilib
+
+DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
+HOMEPAGE="http://www.lsi.com"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/ut_linux_${PN##mega}_${PV}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+RESTRICT="mirror fetch"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="/opt/bin/megamgr"
+
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI"
+ einfo "And place $A in ${DISTDIR}"
+}
+
+pkg_setup() {
+ use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+}
+
+src_install() {
+ newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
+
+ exeinto /opt/bin
+ newexe megamgr.bin megamgr || die
+}
diff --git a/sys-block/megamgr/metadata.xml b/sys-block/megamgr/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/sys-block/megamgr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>