summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /sys-auth
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/Manifest.gzbin10235 -> 10234 bytes
-rw-r--r--sys-auth/pam_abl/Manifest2
-rw-r--r--sys-auth/pam_abl/pam_abl-0.6.0.ebuild18
3 files changed, 6 insertions, 14 deletions
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index 632586ea8f84..207694681f41 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/pam_abl/Manifest b/sys-auth/pam_abl/Manifest
index 383113af0a40..dcad81227475 100644
--- a/sys-auth/pam_abl/Manifest
+++ b/sys-auth/pam_abl/Manifest
@@ -1,3 +1,3 @@
DIST pam-abl-0.6.0.tar.gz 48882 BLAKE2B 6b84901dab29a59e6a9944d2b0870cba940f2fa8fa4930ecf0821ce63db70bbea77d607efc3fa2cc425f2d992c59734c4710d4e45f632f790de6e14118376a6d SHA512 fd4fca672800683f87eba4c9804925d0f1c0e5991a32af7d045787cf571d5d98996d2303460fada4796432916c713973c82c3a70da06d686194e97bfb0e8198e
-EBUILD pam_abl-0.6.0.ebuild 1151 BLAKE2B d9084de95e00205dead7ce5a0f4bee45759803b52a057947723026adccd370e48f75ddc392b7926e4a33978b1560e671f163fb14303bf6626c71ffd6612d7429 SHA512 4e1cbb331741d09829f26d320d760fa69bbed24c364a63e1abf1cc607ebd0c15d07a49021f6ab64ec6ce3fb7a7e1edaacbc819ad1e1beb6cfc6109e3b9935e23
+EBUILD pam_abl-0.6.0.ebuild 853 BLAKE2B e8d551dea21782bdb1aa75956bf6eb35b94be3bb828c0664c9878503d5cb12e2f92ef0196c01893965d8e97876aa3658d3475100be68d82e658533401b1e222a SHA512 9fd9796974424e60cf89a5d8254394e3c96ded31fcb6224063779c2d152c7b9a7b4cf4c13de6442347b42188f78bbbe33bc0f46419c9c035fa46e63ead05962b
MISC metadata.xml 1055 BLAKE2B 0bd9b766d4935216650f179a8bd71ee4e521a8981192cfa444d37facde51b6973fcdd5798e1ff35d06e068d86eb27fc9f11e310257a92bdad6494a8bfeca5c6e SHA512 515ab1d55ae47bdf1b69f637ff4392fe2eb70cddd9b96bbdc8da7b6459e5ea06de15feb7e377f03e7b61bac0cab2fb55b2fbab4b991039fa0e4861b04fd76f80
diff --git a/sys-auth/pam_abl/pam_abl-0.6.0.ebuild b/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
index 450c5c2e55b7..d1dafd1016f5 100644
--- a/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
+++ b/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_PN="${PN/_/-}"
MY_P="${MY_PN}-${PV}"
-inherit flag-o-matic pam cmake-utils db-use multilib
+inherit cmake db-use pam
DESCRIPTION="PAM module for blacklisting hosts and users repeatedly failed authentication"
HOMEPAGE="http://pam-abl.sourceforge.net/"
@@ -15,7 +15,6 @@ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
DEPEND=">=sys-libs/pam-0.78-r2
>=sys-libs/db-4.2.52_p2:="
@@ -31,20 +30,13 @@ src_configure() {
-DDB_LINK_DIR=/usr/$(get_libdir)
-DDB_LIBRARY=$(db_libname)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodir $(getpam_mod_dir)
mv "${D}"/usr/lib/security/*.so "${D}"/"$(getpam_mod_dir)" || die
dodoc doc/*.txt README
}
-
-pkg_preinst() {
- if has_version "~${CATEGORY}/${PN}-0.5.0" ; then
- ewarn "Note: the 0.5.0 release named the module 'pam-abl.so' by accident; this version"
- ewarn "fixes that and uses 'pam_abl.so' again. Please update your config files."
- fi
-}