summaryrefslogtreecommitdiff
path: root/sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild')
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild
new file mode 100644
index 000000000000..7a72c9087c3f
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Command line tool for the YubiKey PIV application"
+SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/openssl:0=[-bindist]
+ sys-apps/pcsc-lite
+"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}/${P}-openssl110.patch" )
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "/PKG_CHECK_MODULES(\[CHECK/d" configure.ac || die
+ sed -i -e "s/@CHECK_CFLAGS@//" -e "s/@CHECK_LIBS@//" */*/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ rm "${D}"/usr/$(get_libdir)/*.la || die
+}