summaryrefslogtreecommitdiff
path: root/sys-auth/yubico-piv-tool/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-auth/yubico-piv-tool/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-auth/yubico-piv-tool/files')
-rw-r--r--sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-tests-optional.patch39
-rw-r--r--sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-ykcs11-threads.patch29
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-tests-optional.patch b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-tests-optional.patch
new file mode 100644
index 000000000000..6653ef2949c0
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-tests-optional.patch
@@ -0,0 +1,39 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -125,7 +125,9 @@
+ find_libcrypto()
+ include_directories(${LIBCRYPTO_INCLUDE_DIRS})
+
++if (BUILD_TESTING)
+ enable_testing()
++endif()
+ find_package(codecov)
+
+ add_subdirectory (lib)
+--- a/lib/CMakeLists.txt
++++ b/lib/CMakeLists.txt
+@@ -92,4 +92,6 @@
+
+ install(FILES ykpiv.pc DESTINATION ${YKPIV_INSTALL_PKGCONFIG_DIR})
+
++if (BUILD_TESTING)
+ add_subdirectory(tests)
++endif ()
+--- a/tool/CMakeLists.txt
++++ b/tool/CMakeLists.txt
+@@ -78,4 +78,6 @@
+ install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/yubico-piv-tool.1" DESTINATION "${YKPIV_INSTALL_MAN_DIR}/man1")
+ endif(MAN_PAGE)
+
++if (BUILD_TESTING)
+ add_subdirectory(tests)
++endif ()
+--- a/ykcs11/CMakeLists.txt
++++ b/ykcs11/CMakeLists.txt
+@@ -102,4 +102,6 @@
+
+ install(FILES ykcs11.pc DESTINATION ${YKPIV_INSTALL_PKGCONFIG_DIR})
+
++if (BUILD_TESTING)
+ add_subdirectory(tests)
++endif ()
diff --git a/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-ykcs11-threads.patch b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-ykcs11-threads.patch
new file mode 100644
index 000000000000..cd85616b5e6a
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-ykcs11-threads.patch
@@ -0,0 +1,29 @@
+--- a/ykcs11/CMakeLists.txt
++++ b/ykcs11/CMakeLists.txt
+@@ -30,7 +30,7 @@
+ link_directories(${PCSC_LIBRARY_DIRS})
+ add_definitions(-DCRYPTOKI_EXPORTS)
+ if(NOT WIN32)
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -pthread")
+ endif(NOT WIN32)
+
+ set(
+@@ -63,7 +63,7 @@
+ # static library
+ if(BUILD_STATIC_LIB)
+ add_library(ykcs11 STATIC ${SOURCE})
+- target_link_libraries(ykcs11 ${LIBCRYPTO_LDFLAGS} ykpiv_static)
++ target_link_libraries(ykcs11 ${LIBCRYPTO_LDFLAGS} -pthread ykpiv_static)
+ set_target_properties (ykcs11 PROPERTIES COMPILE_FLAGS "-DSTATIC ")
+ if(WIN32)
+ set_target_properties(ykcs11 PROPERTIES OUTPUT_NAME ykcs11_static)
+@@ -73,7 +73,7 @@
+
+ # dynamic library
+ add_library(ykcs11_shared SHARED ${SOURCE})
+-target_link_libraries(ykcs11_shared ${LIBCRYPTO_LDFLAGS} ykpiv_shared)
++target_link_libraries(ykcs11_shared ${LIBCRYPTO_LDFLAGS} -pthread ykpiv_shared)
+ set_target_properties(ykcs11_shared PROPERTIES SOVERSION ${SO_VERSION} VERSION ${VERSION})
+ set_target_properties(ykcs11_shared PROPERTIES INSTALL_RPATH "${YKPIV_INSTALL_LIB_DIR}")
+ if(WIN32)