summaryrefslogtreecommitdiff
path: root/sys-auth/ssh-ldap-pubkey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /sys-auth/ssh-ldap-pubkey
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'sys-auth/ssh-ldap-pubkey')
-rw-r--r--sys-auth/ssh-ldap-pubkey/Manifest1
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-auth/ssh-ldap-pubkey/Manifest b/sys-auth/ssh-ldap-pubkey/Manifest
index caceaeee4c72..02209928414c 100644
--- a/sys-auth/ssh-ldap-pubkey/Manifest
+++ b/sys-auth/ssh-ldap-pubkey/Manifest
@@ -1,3 +1,4 @@
DIST ssh-ldap-pubkey-1.3.0.tar.gz 14530 BLAKE2B 1de6913e4abb25d441731b3c36b64361f5fa8900c289b1f4ef58776ab0018414d20b4b24716833e1e27e5dc18079ec77c283bab88879e3fb719fc9ad054267ea SHA512 0c675b0bf68ccecdabda5f4f559772fd0d34151794c2a3855e063befffe9777ceb79e99b5649f15e5bd0c4ea40c22f734d1748a8053d49bffea58077b72efe16
+EBUILD ssh-ldap-pubkey-1.3.0-r1.ebuild 1660 BLAKE2B f3fc1ec77eb40fd5f463ebde42423bfde008f87f7a016d1fbc8aebdce3cc756c3984088220dd7c9e69d0ad040cbf8a368d1ef8130def45e2148de433ea8c39af SHA512 449d63b95ed388f8e95015c0782b3ff94afac77b19dc42427bc45d1cc68575f6a6e9cf868aea76e0eab665df9b99771209beab4c2d2850857d05d799f035773c
EBUILD ssh-ldap-pubkey-1.3.0.ebuild 1549 BLAKE2B b3e5ad64260e124a64d27aee8c67d0b83d4087c1852c190a5ee812334384fcf4b6ef44f669d136a777248af74098dca922e6a56466c53107e24cfbfaaef82949 SHA512 6ed615036d12a00aab37eeb2f8b17d06d35dcf2823679d3f795cdf1e8d130159bf8406ee6949ecd32a35d0f91b5873baf7f4e68a5344612259506ea91230d83c
MISC metadata.xml 416 BLAKE2B f3aafc3351de51af856f2b046be4071d01801110e952bca75fceea99f4216c6cceefb97f4b5847136ea3c6f842eb4b088b44958a31e5c0ca9dc0c739cc06e404 SHA512 a58364a55b4ff512e42eaa31b2003b40ab16db428e5305d8637d166e7357dadad3f608ccbe01e9bae8e41e996ea6bba216865df7bcc662553082be812a7f7ec6
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..628ee8f4f193
--- /dev/null
+++ b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
+HOMEPAGE="https://github.com/jirutka/ssh-ldap-pubkey"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/jirutka/${PN}/${PN}.git"
+
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+MY_CDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.0[${PYTHON_USEDEP}]
+ virtual/logger"
+
+DEPEND="
+ ${MY_CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-describe[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+# We need to block previous net-misc/openssh packages
+# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
+RDEPEND="${MY_CDEPEND}
+ !net-misc/openssh[ldap]"
+
+DOCS=( README.md CHANGELOG.adoc )
+
+src_prepare() {
+ sed -i -e 's/pyldap/python-ldap >= 3.0/' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/openldap/schema
+ doins etc/openssh-lpk.schema
+
+ local MY_DOCDIR="/usr/share/doc/${PF}/examples"
+ insinto "${MY_DOCDIR}"
+ doins etc/ldap.conf
+
+ # We don't want to compress this small file to allow user
+ # to diff configuration against upstream's default
+ docompress -x "${MY_DOCDIR}"
+}