summaryrefslogtreecommitdiff
path: root/sys-auth/ssh-import-id
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-auth/ssh-import-id
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-auth/ssh-import-id')
-rw-r--r--sys-auth/ssh-import-id/Manifest3
-rw-r--r--sys-auth/ssh-import-id/metadata.xml9
-rw-r--r--sys-auth/ssh-import-id/ssh-import-id-5.11.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-auth/ssh-import-id/Manifest b/sys-auth/ssh-import-id/Manifest
new file mode 100644
index 000000000000..5252ea3d3152
--- /dev/null
+++ b/sys-auth/ssh-import-id/Manifest
@@ -0,0 +1,3 @@
+DIST ssh-import-id-5.11.tar.gz 146064 BLAKE2B d869ec480d224aa906ef08b5b9acfbf9324d67bffafadcf1c0adae108ad53e76cdfbcf0d1905a947bda5df507fbd69e7ee121890bc48e452ca67c5acd92ac18c SHA512 49703b8b9c127f13bf0626fd013318b9498ec8a67a060fb7607c7a1894da3e3e3e7e995c9b68af8375237f4031d06abda20f2a9a73a1fabbe33055f2f434716b
+EBUILD ssh-import-id-5.11.ebuild 643 BLAKE2B ae3a39d8caae12c70b5de7d2cd22d17aeab0c6f822638519406120564f4cbe450bf85ce5daf2813512a748ea5fca6973d89c153fb4020830985a030403e58946 SHA512 4abe9d31d0192b251b4de025d04be133d4c14cf857811daf9bedb29b08971017d1ca86c15db2914190764af598665485df3152c93eabb79f69bfab8f42e74028
+MISC metadata.xml 277 BLAKE2B c345d754d34cb228e1b27283b6a38bf4e4e87925b27cc8ca7bd1f8a752be7a3fede5ba13df3bb692a5cb3187476767c89fb1205dd8591a183cefe4b8f8b2e127 SHA512 71ba86560b0ee47075fb4bb3e953b5a39fff709ec53cc1c8f795df63f996b4377b9a367057512b7d620764d6744cb92ab2943aeeeba52b940c3a3cffdd270675
diff --git a/sys-auth/ssh-import-id/metadata.xml b/sys-auth/ssh-import-id/metadata.xml
new file mode 100644
index 000000000000..fd9ff4351985
--- /dev/null
+++ b/sys-auth/ssh-import-id/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/sys-auth/ssh-import-id/ssh-import-id-5.11.ebuild b/sys-auth/ssh-import-id/ssh-import-id-5.11.ebuild
new file mode 100644
index 000000000000..7b988386b2a9
--- /dev/null
+++ b/sys-auth/ssh-import-id/ssh-import-id-5.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to securely retrieve an SSH public key and install it locally"
+HOMEPAGE="https://launchpad.net/ssh-import-id"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman usr/share/man/man1/ssh-import-id.1
+}