summaryrefslogtreecommitdiff
path: root/sys-auth/solo1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-auth/solo1
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-auth/solo1')
-rw-r--r--sys-auth/solo1/Manifest3
-rw-r--r--sys-auth/solo1/metadata.xml19
-rw-r--r--sys-auth/solo1/solo1-0.1.1.ebuild39
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/solo1/Manifest b/sys-auth/solo1/Manifest
new file mode 100644
index 000000000000..e25fb563ac15
--- /dev/null
+++ b/sys-auth/solo1/Manifest
@@ -0,0 +1,3 @@
+DIST solo1-0.1.1.tar.gz 39300 BLAKE2B 3d486d7d515acf03131ef640e38f804f10b4601db37d2b668ea50a715e5b0b38e95d16f3dec41a282bfaacf743a531ef6b56f9b688bdbb7d7f8acc56bdd1d77c SHA512 7e345059205f8753d7d89a22091316f5a529e5afedd82f7a03acbe494035479ef28731cc2b91e8d46058ce638a0e420db8c5f57fcedfcc39b6d07de5eda86f93
+EBUILD solo1-0.1.1.ebuild 1087 BLAKE2B 67b0d3c4d8c4b2dd02c0f4d5fb53dcbfe5adb9d6f584e6b9f4712bb3273461ab4b28ea01b66c9ba06f24f0b14f58c357c01c5b05fa2af56e98ee3b7145b0c5b7 SHA512 e0ff6ae60722bb9eb3754655a3e83bcd82055fa1a3f04dcf95b83e60993dc843d3ab279f41c0b1726003f94025b4f3aa10c700e51e8673029a3a594f58996005
+MISC metadata.xml 703 BLAKE2B f783bce450c4dd2231e6ffbe678c074b630fafa7fa2d75b296cc3e9d1dec11c4caa30182f4c09d15e20b6e4338b03b33961e01cdbde08b4bd05c6b90cbe35583 SHA512 bfb1e4a6cc78ea489411280ac1a8c649690fab10540698dc865daea0ddccce6bd5c5221bf72774d13755a998378d38ba14a9731664447baccbb8be2f795d0d19
diff --git a/sys-auth/solo1/metadata.xml b/sys-auth/solo1/metadata.xml
new file mode 100644
index 000000000000..d85a5fb1d267
--- /dev/null
+++ b/sys-auth/solo1/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The command-line tool 'solo1' provided by this package can be used to reset
+ a SoloKeys Solo 1, set/change the PIN, generate credentials, interact
+ with the on-board TRNG, update the firmware, and more. See the output
+ of 'solo1 key --help' for more information.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">solokeys/solo1-cli</remote-id>
+ <remote-id type="pypi">solo1</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/solo1/solo1-0.1.1.ebuild b/sys-auth/solo1/solo1-0.1.1.ebuild
new file mode 100644
index 000000000000..d2d01f96ae74
--- /dev/null
+++ b/sys-auth/solo1/solo1-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and Python library for SoloKeys Solo 1"
+HOMEPAGE="https://github.com/solokeys/solo1-cli"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~riscv"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt 0.1.1; then
+ ewarn "Note that since version 0.1.1 the CLI executable is called '${PN}' rather than 'solo'"
+ ewarn "The old name can still be used for now but is deprecated"
+ break
+ fi
+ done
+ fi
+}