summaryrefslogtreecommitdiff
path: root/sys-auth/solo1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
commit063e5b486db858a2b1ecec798af89f5484d475bd (patch)
tree490932df05aadb9cbb3611e63a31507953ab5c91 /sys-auth/solo1
parenta0953f7ac639d8e180f62ab3364ccf9af71f783d (diff)
gentoo auto-resync : 27:02:2023 - 03:59:17
Diffstat (limited to 'sys-auth/solo1')
-rw-r--r--sys-auth/solo1/Manifest1
-rw-r--r--sys-auth/solo1/solo1-0.1.1-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/solo1/Manifest b/sys-auth/solo1/Manifest
index dcf2619bf5eb..a9c9134b8a6a 100644
--- a/sys-auth/solo1/Manifest
+++ b/sys-auth/solo1/Manifest
@@ -1,3 +1,4 @@
DIST solo1-0.1.1.tar.gz 39300 BLAKE2B 3d486d7d515acf03131ef640e38f804f10b4601db37d2b668ea50a715e5b0b38e95d16f3dec41a282bfaacf743a531ef6b56f9b688bdbb7d7f8acc56bdd1d77c SHA512 7e345059205f8753d7d89a22091316f5a529e5afedd82f7a03acbe494035479ef28731cc2b91e8d46058ce638a0e420db8c5f57fcedfcc39b6d07de5eda86f93
+EBUILD solo1-0.1.1-r1.ebuild 1086 BLAKE2B e73447753fb581a08fd9238a2f5e810c8b279d9cd3ccf8e6e04b4a608ac335ec4d7f05f6ded737b5cdd1d844dcd54f36a5b0323072054f2c7059a91882db33fd SHA512 68989ea1124cb12b07d060bbd24fe8c4dc63b65c59fa76eef6c76aa1ff4907615c30c47a5d78e4871ba9fb8121ba03845b353d618b4d94affdb1f16f7af57da1
EBUILD solo1-0.1.1.ebuild 1085 BLAKE2B aebc3117249e81229dac2ebddbd843276e250c618eca3ffdcf8a41fdb559d082d9e0d47d62283d20661dd08cf554544eb428fb3606527b3cdd293a2bd26c8420 SHA512 b65503fa22f179c671080cbe5d9b5f5be91009d846393a24b125e42fb5218aea16d566418569fd2a0d7e7f873ac546e8d886d385459585db2cf7cb8c1c59c1bb
MISC metadata.xml 703 BLAKE2B f783bce450c4dd2231e6ffbe678c074b630fafa7fa2d75b296cc3e9d1dec11c4caa30182f4c09d15e20b6e4338b03b33961e01cdbde08b4bd05c6b90cbe35583 SHA512 bfb1e4a6cc78ea489411280ac1a8c649690fab10540698dc865daea0ddccce6bd5c5221bf72774d13755a998378d38ba14a9731664447baccbb8be2f795d0d19
diff --git a/sys-auth/solo1/solo1-0.1.1-r1.ebuild b/sys-auth/solo1/solo1-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..bd6a6de61f44
--- /dev/null
+++ b/sys-auth/solo1/solo1-0.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and Python library for SoloKeys Solo 1"
+HOMEPAGE="https://github.com/solokeys/solo1-cli"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt 0.1.1; then
+ ewarn "Note that since version 0.1.1 the CLI executable is called '${PN}' rather than 'solo'"
+ ewarn "The old name can still be used for now but is deprecated"
+ break
+ fi
+ done
+ fi
+}