summaryrefslogtreecommitdiff
path: root/sys-auth/seatd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-auth/seatd
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-auth/seatd')
-rw-r--r--sys-auth/seatd/Manifest5
-rw-r--r--sys-auth/seatd/files/seatd.initd4
-rw-r--r--sys-auth/seatd/metadata.xml12
-rw-r--r--sys-auth/seatd/seatd-0.4.0.ebuild48
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild47
5 files changed, 116 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
new file mode 100644
index 000000000000..31466a6671ab
--- /dev/null
+++ b/sys-auth/seatd/Manifest
@@ -0,0 +1,5 @@
+AUX seatd.initd 87 BLAKE2B e88a8c353191ad9b69c0ee263aee7a050333d43e8dd26c8b3ee40cfbcb17f9b7a9391720ac34d19f375a880fae8178cd7dfc0b45cc9565b4b073bbe43cadf5ce SHA512 a19171b55e6650a9237f89258d92aba18508684412fe8a072387c505945b8e54557bd52261de76230553a572d627f40e00770087040111a7473fadfe3c33c931
+DIST seatd-0.4.0.tar.gz 34242 BLAKE2B 295ee18736b5f7e1b06013d00514321aad5fb09c285690cfbd78833a9efbfeb2cfaef69c075fb096fedaac42ff249ee1a43593dbd03132770c1be293ffe7ddc1 SHA512 498ab4040c19ff90842bf82f580ba24c2c98e0aded7ba636dcffc80f6bfd8869eec3e87e784455b66e2b69786b2fc6e7315b2867effa825440759d58e391378c
+EBUILD seatd-0.4.0.ebuild 987 BLAKE2B 0a1b3fb32190f69559bcfddc1f135131988f2885513e6625a5050462daae7e93a8e38fd7df86f9bf36fa8f36773cacaf4ccab13a7e9619dc7071bb095be8f189 SHA512 30b2ad7adc0ddcf6b9719e0efd7f4f468eae26e2bba5737bf6bc73d2cc2385eebb756f27349bda4d07b0a984e1d675b93ba7d06d0ddab861e6da7bc19d73303a
+EBUILD seatd-9999.ebuild 986 BLAKE2B 3fc01db4ea08a49215179dd4db19a7816f6c33ef221bbfd8e8bff99a299e635d51e8fbd12a216781de4196712ea93eba8c9302e00d2696ae3009dac57f4fde6f SHA512 f8425b2cafa0e44bf7035374f4ce6358fda18dd6ceada20fc5cfd6344ec8c65e784c6cc7d952d3b88e6aada6bd7749de8a754fc1963abe9829521d6646ce4dc8
+MISC metadata.xml 371 BLAKE2B 91b47ce16cdda23db5bd32abf120406a37fe6c17a0f412b7566ca82168ffbe30a5659a9f49326ecc752a147364bc0484b1342fbbb4409db1496ed86f148ad942 SHA512 2942272dd7bba259e32f6a6169d47e6d56707ecdaa0bf9d04a21be5bdc687734c59c0895361555ab6c34b113fd391f7177c26b2e08e0b298ba48eaeb70ec8e7d
diff --git a/sys-auth/seatd/files/seatd.initd b/sys-auth/seatd/files/seatd.initd
new file mode 100644
index 000000000000..f95a52f15632
--- /dev/null
+++ b/sys-auth/seatd/files/seatd.initd
@@ -0,0 +1,4 @@
+#!/sbin/openrc-run
+supervisor=supervise-daemon
+command="seatd"
+command_args="-g video"
diff --git a/sys-auth/seatd/metadata.xml b/sys-auth/seatd/metadata.xml
new file mode 100644
index 000000000000..fa389813e2dd
--- /dev/null
+++ b/sys-auth/seatd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>contact@hacktivis.me</email>
+ <name>Haelwenn (lanodan) Monnier</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/seatd/seatd-0.4.0.ebuild b/sys-auth/seatd/seatd-0.4.0.ebuild
new file mode 100644
index 000000000000..06bf3fce1be6
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/seatd.initd" seatd
+}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
new file mode 100644
index 000000000000..3d89eb8e867b
--- /dev/null
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/seatd.initd" seatd
+}