summaryrefslogtreecommitdiff
path: root/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
index 65ed2776fbf3..3d438c81c688 100644
--- a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
+++ b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
@@ -3,17 +3,20 @@
EAPI=7
-MY_PN="${PN}-1"
-MY_P="${MY_PN}-${PV}"
-inherit cmake-utils
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake-utils kde.org
DESCRIPTION="Qt wrapper around polkit-1 client libraries"
HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
-SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.xz"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${KDE_ORG_NAME}-${PV}"
+fi
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="debug"
RDEPEND="
@@ -28,8 +31,6 @@ DEPEND="${RDEPEND}"
DOCS=( AUTHORS README README.porting TODO )
-S="${WORKDIR}/${MY_P}"
-
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF