summaryrefslogtreecommitdiff
path: root/sys-auth/passwdqc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-auth/passwdqc
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-auth/passwdqc')
-rw-r--r--sys-auth/passwdqc/Manifest4
-rw-r--r--sys-auth/passwdqc/metadata.xml3
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.0.ebuild61
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-auth/passwdqc/Manifest b/sys-auth/passwdqc/Manifest
index 5b72f2816563..d272a95ba72c 100644
--- a/sys-auth/passwdqc/Manifest
+++ b/sys-auth/passwdqc/Manifest
@@ -1,3 +1,5 @@
DIST passwdqc-1.4.0.tar.gz 55219 BLAKE2B 3f96a2d219ee23f11db2ad8ba433eaa56b97a263ad1a49159e0356b779cb4486ec9aa74cd7002fdd6d273e5a7bae4fe1b94e02f60256d331e5afc30d63e81360 SHA512 b9be6632688a1d7d929ec546679a366a67d44e7841e106c7f739a8e0656842866125160c87b04c8e0b3189a3e85eb182aa789196f68925b2f8ec71cd6a479800
+DIST passwdqc-2.0.0.tar.gz 86235 BLAKE2B fa67007ca0477feafd8743eda0899b7e348bf75e00e7ff23b6acdf56a456d75bec89a4b7dead41d7889610669425ff0145d6e7c94db0ce93219de0c5c0b80909 SHA512 7e5c0a32361d604c47ad02f36beff3287f638f2911b398a21b89cea164bf9a161b3bc252e9c660eaa53c5e5fce458d1cb1fd6b2bb308bafdb729c9d7e67f5295
EBUILD passwdqc-1.4.0-r1.ebuild 1273 BLAKE2B 129125327a956fd698b1493d463f50e1c9d8c6d9a85665654ab8778855f676b1ed9d2c3b382499f91bbf7a69c6a4e02d4d1ff64313adc322f9b5693d2fec3810 SHA512 1c4068d4550e463f437e30353b9fe0d20c18b6342560255db3d21b48eabd362c7385f8b4c4647d1064b62210032c484e197de56bc6337d7745ef43efd8308e63
-MISC metadata.xml 243 BLAKE2B f7576f14be2c0aa21ca2c7147133e4a4132d6559cca1519745dd2f4ea912b3856950c7645e13d2317f38c80ba93b13d47370260920241a5ab60a4eae59f2cf33 SHA512 0dc1f228861badffd9c4175af734b72435dc7c60d369a3d9ff946c5b98b3f2f49af7d433f7ec5fc2afee7015b8f75259e8debe150b1bcffa0cb66425bed10d8d
+EBUILD passwdqc-2.0.0.ebuild 1282 BLAKE2B 834853e67e9c78cd2f84c9ac2f06f0acd196060f18d0ddca51c8f9f0c9cf89672e963c64aacb821561b66616b69d21f7eb5d6d04cf8091422f08659a2d38d48a SHA512 dd89b3d468c5d79ee89ea7289064f709b70cb731ed7810bab870c7d3388be76c12f291172e76f8dce8996965cf33e6facd4916f47f9c5a9d729c65e6bd5b08de
+MISC metadata.xml 322 BLAKE2B 539430fc1d4d9cff3e27ab5769b9385dc822dc666accfba89a75c8228103132e0056ebbba0f16399bdf6cccb7bcf7f52de55e27a9da9cc12c38a38674bf67fb2 SHA512 8762169c70c490e144d0bc6239265e259ee1f5e2dccf75e87aa236cbc884c243432da7082ba078e20b4de7848d0c3760d8e7a3e8dac3650e3799a012a893e9be
diff --git a/sys-auth/passwdqc/metadata.xml b/sys-auth/passwdqc/metadata.xml
index 203fa55c746f..9f6f3f998119 100644
--- a/sys-auth/passwdqc/metadata.xml
+++ b/sys-auth/passwdqc/metadata.xml
@@ -5,4 +5,7 @@
<email>zlogene@gentoo.org</email>
<name>Mikle Kolyada</name>
</maintainer>
+<upstream>
+ <remote-id type="github">openwall/passwdqc</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/sys-auth/passwdqc/passwdqc-2.0.0.ebuild b/sys-auth/passwdqc/passwdqc-2.0.0.ebuild
new file mode 100644
index 000000000000..53fea839ad89
--- /dev/null
+++ b/sys-auth/passwdqc/passwdqc-2.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Password strength checking library (and PAM module)"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/${PN}/${P}.tar.gz"
+
+LICENSE="Openwall BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/pam"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/$(get_libdir)/security/pam_passwdqc.so
+ /usr/$(get_libdir)/libpasswdqc.so.1"
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:`uname -s`:Linux:' Makefile || die
+
+ # ship our own default settings
+ cat <<- EOF > "${S}/passwdqc.conf"
+ min=8,8,8,8,8
+ max=40
+ passphrase=3
+ match=4
+ similar=deny
+ random=47
+ enforce=everyone
+ retry=3
+ EOF
+
+}
+
+_emake() {
+ emake -j1 \
+ SHARED_LIBDIR="/usr/$(get_libdir)" \
+ SECUREDIR="$(getpam_mod_dir)" \
+ CONFDIR="/etc/security" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake pam utils
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install_lib install_pam install_utils
+ dodoc README PLATFORMS INTERNALS
+}