summaryrefslogtreecommitdiff
path: root/sys-auth/passwdqc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-auth/passwdqc
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-auth/passwdqc')
-rw-r--r--sys-auth/passwdqc/Manifest2
-rw-r--r--sys-auth/passwdqc/passwdqc-1.4.0-r1.ebuild (renamed from sys-auth/passwdqc/passwdqc-1.4.0.ebuild)14
2 files changed, 15 insertions, 1 deletions
diff --git a/sys-auth/passwdqc/Manifest b/sys-auth/passwdqc/Manifest
index c3bb90e0d7e5..3a5fe0c20852 100644
--- a/sys-auth/passwdqc/Manifest
+++ b/sys-auth/passwdqc/Manifest
@@ -2,5 +2,5 @@ AUX passwdqc-1.3.0-build.patch 1773 BLAKE2B e954aa56f4f12c57430b9c53cac9220360b6
DIST passwdqc-1.3.0.tar.gz 48833 BLAKE2B bf6353749376ca8b52a8aac89b05561d4a0dde54133361b77228dd4d35f2e1e75f0b53a0f9c4fc2f6be5717110c1d762e2aa76f6461281b60fa3bdc9b19f2f7d SHA512 d9c2fd075ed4ff1f1dfa63fe40010d446abf8db306cacc77fd1e429fbd2dd1a6d2e4e91df46beb4c30bc30ff0cdd183ba85cefd362455ead9629d3a1c4eefece
DIST passwdqc-1.4.0.tar.gz 55219 BLAKE2B 3f96a2d219ee23f11db2ad8ba433eaa56b97a263ad1a49159e0356b779cb4486ec9aa74cd7002fdd6d273e5a7bae4fe1b94e02f60256d331e5afc30d63e81360 SHA512 b9be6632688a1d7d929ec546679a366a67d44e7841e106c7f739a8e0656842866125160c87b04c8e0b3189a3e85eb182aa789196f68925b2f8ec71cd6a479800
EBUILD passwdqc-1.3.0.ebuild 1711 BLAKE2B 19a51a550eb5824a35341c0638c1c1fec3d9e5ce73772151b6e4eae9afa99211b562519a796aab117f4ebfad16e2c8716cb067ebc1162da4d021694f38102f72 SHA512 8e245c777ef722106cc0e89d413dfc83b434e9b90ff9559eea47d90245f4e9b8bcf9ed8a15d42922cef7084c8e1be618d60aca6b99b06dc73a619638aecb28e0
-EBUILD passwdqc-1.4.0.ebuild 1072 BLAKE2B 992115d9d859f36e0713b14e2691f3e3ba0a6fc78a37547274e28fdf6a8bf3350f14503dc2994f71334cd9681d360b4c7dc936ca6f5b87530d4850826b2b7330 SHA512 2168660a75fbf16b82a6faf620867d2dd7ed15c3803b621b1359ffbb7cd8d0abc5c105a5a603ba283eb15ef1881a60b18b87928b7f18b91b37ad3c093a40e046
+EBUILD passwdqc-1.4.0-r1.ebuild 1282 BLAKE2B 80353f2c519fd5afb65a4d567948407088e3cad8605ac6f87f34aec548f5e27d277619ddbe4f7140dbd59bc823b89fc22a1c9ce5bf8c8bb3d34c022b419c137d SHA512 30806db924279bb17fd0f1466628f51c0bd7a7e110ff2b4959fc6c76f9222f9d232678a6906ad802ec50a01f1f0edae1de57a24ca3cfd0ab8b6b3ff9a4452abc
MISC metadata.xml 328 BLAKE2B 708e739a28626b1451952b869907c4c2513774329dfdac794178b468ffe1044db82ea5c015c641a5142f1f6ee6176545193e97beed1698f7f8c42a3d38e3f84a SHA512 383c32b28259f9a70406eb6c9a3d05143212a63c347019143983c3e6a2c48eb9a32ed7e8e50c99339b65c60d680b530770c4fa3e826c6e746429274814716d97
diff --git a/sys-auth/passwdqc/passwdqc-1.4.0.ebuild b/sys-auth/passwdqc/passwdqc-1.4.0-r1.ebuild
index 8a292a46e9f3..3861096f8540 100644
--- a/sys-auth/passwdqc/passwdqc-1.4.0.ebuild
+++ b/sys-auth/passwdqc/passwdqc-1.4.0-r1.ebuild
@@ -24,12 +24,26 @@ pkg_setup() {
src_prepare() {
default
sed -i -e 's:`uname -s`:Linux:' Makefile || die
+
+ # ship our own default settings
+ cat <<- EOF > "${S}/passwdqc.conf"
+ min=8,8,8,8,8
+ max=40
+ passphrase=3
+ match=4
+ similar=deny
+ random=47
+ enforce=everyone
+ retry=3
+ EOF
+
}
_emake() {
emake -j1 \
SHARED_LIBDIR="/usr/$(get_libdir)" \
SECUREDIR="$(getpam_mod_dir)" \
+ CONFDIR="/etc/security" \
CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)" \