summaryrefslogtreecommitdiff
path: root/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild')
-rw-r--r--sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild b/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
index abb50e927b18..90ea5b5ec52c 100644
--- a/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
+++ b/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit pam toolchain-funcs
+inherit flag-o-matic pam toolchain-funcs
DESCRIPTION="Password strength checking library (and PAM module)"
HOMEPAGE="http://www.openwall.com/passwdqc/"
@@ -40,6 +40,17 @@ src_prepare() {
}
+src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
+ default
+}
+
_emake() {
emake \
SHARED_LIBDIR="/usr/$(get_libdir)" \