summaryrefslogtreecommitdiff
path: root/sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild')
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild b/sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild
new file mode 100644
index 000000000000..eaf84fc6bbfa
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.26-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pam
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-libs/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap:= )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ local myeconfargs=(
+ --with-cr
+ --with-pam-dir="$(getpam_mod_dir)"
+ $(use_with ldap)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ find "${D}" -name '*.la' -delete || die
+}