summaryrefslogtreecommitdiff
path: root/sys-auth/pam_skey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-auth/pam_skey
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-auth/pam_skey')
-rw-r--r--sys-auth/pam_skey/Manifest1
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-auth/pam_skey/Manifest b/sys-auth/pam_skey/Manifest
index f8cb4609fb89..580df10a2017 100644
--- a/sys-auth/pam_skey/Manifest
+++ b/sys-auth/pam_skey/Manifest
@@ -1,4 +1,5 @@
DIST pam_skey-1.1.5-patches-6.tar.xz 9264 BLAKE2B aa3a1f66b5511489ad542af2802ff0aab99d79fdc5bff0cf661b55f1c118cfda2644006ce3d494e6f6fafd85ad2832449fbdaec73ee8edf99a20a3cb2616e9b5 SHA512 c777ed094efe9cbfb275cfb30d036e3a1bd9477b08297815f07156b432a2724f8c08e9e841ef6bf7ba62ccf7df361f541e59024b42164bd35d7eef16da1f75ec
DIST pam_skey-1.1.5.tar.gz 76963 BLAKE2B ded4a4e43b174338cd1beefce65314cc906db928593dd5eba2ba1be9cab33844d8fd38cb7d3b952a29da632b671c468e0dfe7f0f1e0d167397320cd9ca6d35e1 SHA512 12817cedf15a3b2287982e4beab5d3b388239cc0a1e141e66e41759ddb2da7fb9dd0df12202dcc8140db0868c8df1a8d19d5859224179e2419ffefd691cb9834
EBUILD pam_skey-1.1.5-r5.ebuild 1551 BLAKE2B edbab23c1a66829d858422bc9efd670fea2ee5a8a833ee40353c87fbb7c3a6f464d06f7dd3bff4ee7c5539a175f798745c9396508e75ce339f386e71e6a607d8 SHA512 30a05dd63926440d529d3fe6f0252e0e7c2d1a9b40293cd3c123d47afecb55599aa4892200405e81a221b1e6365cfc77af28da1f2d40c3488b83415252e2130d
+EBUILD pam_skey-1.1.5-r6.ebuild 1576 BLAKE2B 735df1184f18c70ee7ceb7af506135f39c383b4cf2e17bbea6271af3e93607c0528bc08470cde9106c797f1bf8eade92ecfdf1fcaa82449011fce3806083b9e2 SHA512 2c37d9b893683c8541f207f07be434eb7788fcc5d15a0490bf9897091e1655d53b4f166dc4341e366272a6cd5fa03a91e8c6e724b009eca8a5a4395524898914
MISC metadata.xml 444 BLAKE2B 5b4fcdf83c82795645ff6f45cc6f3f991067ce348f14a59479206492ab4bacea14c0594d85feaf36873f3f2414f27612f9f3db71647460dd6db93cd5b6fa75ae SHA512 64531817fb541562dbc2340836e0bf3e7241238f96e49b8eee17930084ef21b3b729d1e27e691f1be6a0ba4d3b96e66dfa20c9379d20a7b9da593c6937e8bb4d
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r6.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r6.ebuild
new file mode 100644
index 000000000000..c286358b4e13
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils pam autotools multilib readme.gentoo-r1
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ https://dev.gentoo.org/~ulm/distfiles/${P}-patches-6.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/libnsl:0=
+ >=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}"
+
+PATCHES="${WORKDIR}/patch"
+DOCS="README INSTALL"
+
+src_prepare() {
+ default
+
+ cd autoconf || die
+ mv configure.{in,ac} || die
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+src_install() {
+ default
+
+ DOC_CONTENTS="To use the pam_skey module, you need to configure PAM
+ by adding a line like:
+ \n\nauth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so\n
+ \nto an appropriate place in the /etc/pam.d/system-login file.
+ Consult the README and INSTALL files in /usr/share/doc/${PF}
+ for detailed instructions.
+ \n\nPlease note that calling this module from unprivileged
+ applications, e.g. screensavers, is not supported.
+ \n\nError checking has become stricter in pam_skey-1.1.5-r4;
+ errors returned from the underlying skey library when accessing
+ the S/Key data base will no longer be ignored.
+ Make sure that your PAM configuration is correct."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}