summaryrefslogtreecommitdiff
path: root/sys-auth/pam_mount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /sys-auth/pam_mount
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/Manifest4
-rw-r--r--sys-auth/pam_mount/files/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch52
-rw-r--r--sys-auth/pam_mount/pam_mount-2.16-r1.ebuild44
-rw-r--r--sys-auth/pam_mount/pam_mount-2.16.ebuild4
4 files changed, 101 insertions, 3 deletions
diff --git a/sys-auth/pam_mount/Manifest b/sys-auth/pam_mount/Manifest
index 0068a159fb03..005bd08b223f 100644
--- a/sys-auth/pam_mount/Manifest
+++ b/sys-auth/pam_mount/Manifest
@@ -1,3 +1,5 @@
+AUX pam_mount-2.16-crypto-Add-support-for-LUKS2.patch 1547 BLAKE2B f6c0ceba9ac683bd852606988688c18321b36192ea3e3d4b7443ac225b53446d594aafa78123a84847dd0b622cea54150a32a0852b572842f6f48fa7bf5e59e5 SHA512 7b37add4202fbbfef9ccbab10f4c3fc10da7dc976adab8c550ee2197b92e7f8f1db06186d155d0ae05b8c775d919d754071854a69c5d7f2a54c5b890f33bbc8f
DIST pam_mount-2.16.tar.xz 312316 BLAKE2B 5954af8f8bf8b9cb47e1c07dc0d5fc5c4db099eeca5de90a3a53dc65aac0a2a6fba3f99c4d91d12f53b13abb5d3bae262b42536434553872a36ec108dc8d2c0c SHA512 3a579d7287cfcaef831d3e54d3e912407b65a966303e81c47f445d601f38f866ce04326e3d37a061f74f97b9cfb201e56109f57e55699d15d8f947ae2b91c8e3
-EBUILD pam_mount-2.16.ebuild 898 BLAKE2B 35b563d37b700f117a3574df6bf81b3b80ce84d31e45fae748750c9723a9acf223aae9198a181ea495070bf011380374e09e76000ff2627f379bbf881530d121 SHA512 4cee527f52a845f669752c59a583ba88b0be841a98e939567c4be2691d4385caa1af57f026ddc8c1d8cfeea54e3f753e9f55d6e12169dab7eabf658738b0d476
+EBUILD pam_mount-2.16-r1.ebuild 979 BLAKE2B 09b9f7b7174d5048a038885b8de36f5b9021dc17ed5933d2ec0b1f9f10193a9e19b7ba64a8a66df1f1ea7821844bb2997596d45182605a5ac59aafe6d94b72c4 SHA512 6c320d44ad95fd482b370016a8030d2c7b6b268a940357882e5a28e40ec55316ec240f8c2581b548cef7fab988360cb324b68c23f2bd21129624f5ebd38622b4
+EBUILD pam_mount-2.16.ebuild 897 BLAKE2B 2ae2a7f8ff32724e6379041f7073a28cc5b2c04dd6c2f65dd66151af7a53c54d0b799b1b5553809759e31e227799e906932a7dc53af56dbc4817ed8238f63861 SHA512 6e8dee0b91929b08e72e243346e45f9c091d6b6d2b5ac7bc08db0ce2e76e0812ab9b77397cad4c82b8cdadb649e9815598d74aca0148c72a2f4833c78a7b68bf
MISC metadata.xml 402 BLAKE2B 001c9702dee12640adcb05c6a6d9750e13ac0d45ebdb46859fc19e4071af76fcde847163f59b876992169968fefed8423352eec067ecf2ae6baa60dfdf412cc4 SHA512 546dd1bb071d1cc634250930b70328fc83f8bb4ac8a857fc3ccddadae5fcfb48d0a40adb0845e07535c63fd2dd2e6ef91779c0b48b6d147efa7aeb7fcde412e1
diff --git a/sys-auth/pam_mount/files/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch b/sys-auth/pam_mount/files/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch
new file mode 100644
index 000000000000..437f359277d5
--- /dev/null
+++ b/sys-auth/pam_mount/files/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch
@@ -0,0 +1,52 @@
+From d4434c05e7c0cf05d87089404cfa2deedc60811a Mon Sep 17 00:00:00 2001
+From: Ingo Franzki <ifranzki@linux.ibm.com>
+Date: Mon, 29 Oct 2018 16:47:40 +0100
+Subject: [PATCH] crypto: Add support for LUKS2
+
+Cryptsetup version 2.0 added support for LUKS2.
+This patch adds support for mounting LUKS2 volumes with
+pam_mount.
+
+Signed-off-by: Ingo Franzki <ifranzki@linux.ibm.com>
+---
+ src/crypto-dmc.c | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/crypto-dmc.c b/src/crypto-dmc.c
+index d0ab6ca..abd0358 100644
+--- a/src/crypto-dmc.c
++++ b/src/crypto-dmc.c
+@@ -21,6 +21,12 @@
+ #include "libcryptmount.h"
+ #include "pam_mount.h"
+
++#ifndef CRYPT_LUKS
++ #define CRYPT_LUKS NULL /* Passing NULL to crypt_load will
++ default to LUKS(1) on older
++ libcryptsetup versions. */
++#endif
++
+ /**
+ * dmc_is_luks - check if @path points to a LUKS volume (cf. normal dm-crypt)
+ * @path: path to the crypto container
+@@ -48,7 +54,7 @@ EXPORT_SYMBOL int ehd_is_luks(const char *path, bool blkdev)
+
+ ret = crypt_init(&cd, device);
+ if (ret == 0) {
+- ret = crypt_load(cd, CRYPT_LUKS1, NULL);
++ ret = crypt_load(cd, CRYPT_LUKS, NULL);
+ if (ret == -EINVAL)
+ ret = false;
+ else if (ret == 0)
+@@ -106,7 +112,7 @@ static bool dmc_run(const struct ehd_mount_request *req,
+ #endif
+ }
+
+- ret = crypt_load(cd, CRYPT_LUKS1, NULL);
++ ret = crypt_load(cd, CRYPT_LUKS, NULL);
+ if (ret == 0) {
+ ret = crypt_activate_by_passphrase(cd, mt->crypto_name,
+ CRYPT_ANY_SLOT, req->key_data, req->key_size, flags);
+--
+2.21.0
+
diff --git a/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild b/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild
new file mode 100644
index 000000000000..45d0091b7b47
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
+ ssl? ( dev-libs/openssl:0= )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+PATCHES=(
+ "${FILESDIR}"/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch
+)
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}
diff --git a/sys-auth/pam_mount/pam_mount-2.16.ebuild b/sys-auth/pam_mount/pam_mount-2.16.ebuild
index becc55fc9ca3..396e2ed710c9 100644
--- a/sys-auth/pam_mount/pam_mount-2.16.ebuild
+++ b/sys-auth/pam_mount/pam_mount-2.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ IUSE="crypt ssl selinux"
COMMON_DEPEND=">=sys-libs/pam-0.99
>=sys-libs/libhx-3.12.1
>=dev-libs/libxml2-2.6
- crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
ssl? ( dev-libs/openssl:0= )
selinux? ( sys-libs/libselinux )"
DEPEND="${COMMON_DEPEND}