summaryrefslogtreecommitdiff
path: root/sys-auth/nss_ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sys-auth/nss_ldap
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sys-auth/nss_ldap')
-rw-r--r--sys-auth/nss_ldap/Manifest1
-rw-r--r--sys-auth/nss_ldap/nss_ldap-265-r8.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/sys-auth/nss_ldap/Manifest b/sys-auth/nss_ldap/Manifest
index 237ba6ac36e1..28e220d22236 100644
--- a/sys-auth/nss_ldap/Manifest
+++ b/sys-auth/nss_ldap/Manifest
@@ -11,4 +11,5 @@ AUX nss_ldap-265-reconnect-timeouts.patch 2806 BLAKE2B b254a9959892a0a8ecb6e5377
AUX nsswitch.ldap.diff 575 BLAKE2B 9578535ea6cff87ac21fa8f3a0a1b8d727c657a53318b378dd86b4dded15bac950e241af59b15b6898a1ed089d1c481f0615ca7de3ae4e07a231432920af7b52 SHA512 0d08d4dacea0213714cab864300e625158106245eeb34a7d4b983749dd4fa4156d3f36d6c2dd214efdf80cf926c37657eb00651bceb89907286a3310123399a0
DIST nss_ldap-265.tar.gz 280976 BLAKE2B 31b233ef7680204abfb62408141609b9489e133327c787c59afedd9ac41194189bde26d1f3b0a885622f57ec769ddee2bdf7d274b9584d4d5002d1c016c86892 SHA512 c4584682968861dd5880992fe7d11c6005d94f0c17252ab1cda04380fd7a81b419ba7e87d0efa44c24c5ce5bf76b9fd8331034dddb4f1400f132eb2192472077
EBUILD nss_ldap-265-r5.ebuild 3982 BLAKE2B c1c0fe18519694473ec42f310e6f3e45ba4f3adcb511d57a60b2c4ca61218276eb33307828068f9ec837559a647c7ff71aedf9217674efde016738ec4bbaf469 SHA512 a505439d2138460a055c6d00db152937493dc1ebe96316be937065ebfbb25de6345979e5e184f572832347dc7656904d03faa5a8abbbf64bcf4ca3ea4e9d4ede
+EBUILD nss_ldap-265-r8.ebuild 3728 BLAKE2B 52967dd0d189451057c9dac58ce5cee507e90dd3b1501a835d73b3297f1d0f85dcd5f4786d9f6273cb0b280f640d22ce23bae6a20954059c23cbda7de7abc7b5 SHA512 59aeefcc414fb80abe3634b56c0f983f309415125f0e96c816f5c00cf14c595f57e66c028ebeae195edfe803cb1e32bd6e3959b06ddc155da70a8d2eeb51b1a5
MISC metadata.xml 418 BLAKE2B 0ee38489c1ce6a94df354e507b4e89255abe13a587b6b8887eb234eb1463da037194ad6f3e834e9ce4c5ef6e00c3082706a4b602a2ad39b9ea3eafff71596b22 SHA512 0395ea328ffe10ee708706b9e524ef863716dcb4d762a05546a64c2dbde75ab1ff3ec853c6973e421e0d3a7c837df96adf502aacce726016c4302ab466e1e7a8
diff --git a/sys-auth/nss_ldap/nss_ldap-265-r8.ebuild b/sys-auth/nss_ldap/nss_ldap-265-r8.ebuild
new file mode 100644
index 000000000000..e6ed3ba6fc38
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-265-r8.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fixheadtails multilib-minimal prefix
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="debug kerberos ssl sasl"
+
+DEPEND="
+ >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}]
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.26-r3[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ ssl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<net-fs/autofs-4.1.3
+"
+
+src_prepare() {
+ default
+
+ # Patch is for Prefix
+ # eprefixify is safe on non-Prefix systems, so go unconditional
+ # Note: comment this out or make it conditional on 'use prefix'
+ # if needs rebasing. Don't remove.
+ eapply "${FILESDIR}"/${P}-installdir.patch
+ eprefixify Makefile.am
+
+ # bug 438692
+ eapply -p0 "${FILESDIR}"/${P}-pthread.patch
+
+ eapply -p0 "${FILESDIR}"/nsswitch.ldap.diff
+
+ # Applied by upstream
+ #eapply "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+
+ eapply -p0 "${FILESDIR}"/${PN}-249-sasl-compile.patch
+
+ eapply "${FILESDIR}"/${PN}-265-reconnect-timeouts.patch
+
+ # Applied by upstream
+ #eapply "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
+
+ eapply "${FILESDIR}"/${PN}-257-nss_max_group_depth.patch
+
+ sed -i.orig \
+ -e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
+ "${S}"/ldap.conf \
+ || die
+
+ # Fix head/tail stuff
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
+
+ # Fix build borkage
+ local i
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ "${S}"/$i || die
+ done
+
+ eapply "${FILESDIR}"/${PN}-257.2-gssapi-headers.patch
+
+ # Bug #214750, no automagic deps
+ eapply "${FILESDIR}"/${PN}-264-disable-automagic.patch
+
+ # Upstream forgets the version number sometimes
+ #sed -i \
+ # -e "/^AM_INIT_AUTOMAKE/s~2..~$PV~" \
+ # "${S}"/configure.in || die
+
+ # Include an SONAME
+ eapply "${FILESDIR}"/${PN}-254-soname.patch
+
+ # Fix broken oneshot connections
+ eapply "${FILESDIR}/nss_ldap-265-missing-entries-oneshot.patch"
+
+ sed -i \
+ -e 's, vers_string , PERL5LIB="@top_srcdir@" @top_srcdir@/vers_string ,g' \
+ "${S}"/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ # --enable-schema-mapping
+ --with-ldap-lib=openldap
+ --with-ldap-conf-file="${EPREFIX}/etc/ldap.conf"
+ --enable-paged-results
+ --enable-rfc2307bis
+ $(use_enable ssl)
+ $(use_enable sasl)
+ $(use_enable kerberos krb)
+ )
+
+ use debug && myconf+=( --enable-debugging )
+ use kerberos && myconf+=( --enable-configurable-krb5-ccname-gssapi )
+
+ # Neede to be careful with changing this
+ # bug #581306
+ multilib_is_native_abi && myconf+=( --libdir="${EPREFIX}/$(get_libdir)" )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" \
+ INST_UID=${PORTAGE_USER:-root} \
+ INST_GID=${PORTAGE_GROUP:-root} \
+ install
+}
+
+multilib_src_install_all() {
+ # Dumb /usr/lib* -> /lib* symlinks gone wrong
+ rm -rf "${ED}"/usr/usr || die
+
+ insinto /etc
+ doins ldap.conf
+
+ # Append two blank lines and some skip entries
+ echo >>"${ED}"/etc/ldap.conf || die
+ echo >>"${ED}"/etc/ldap.conf || die
+ sed -i "${ED}"/etc/ldap.conf \
+ -e '$inss_initgroups_ignoreusers ldap,openldap,mysql,syslog,root,postgres' \
+ || die
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ CVSVersionInfo.txt README nsswitch.ldap certutil
+
+ docinto docs
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ elog "If you use a ldaps:// string in the 'uri' setting of"
+ elog "your /etc/ldap.conf, you must set 'ssl on'!"
+}