summaryrefslogtreecommitdiff
path: root/sys-auth/libyubikey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
commit6a7029e0f7370d4d5dfe9e31cc2719a870482392 (patch)
tree28c6c747114eaedfd2db81f86ac2ff3d7d13111e /sys-auth/libyubikey
parent5e41a38157bb40e8513e8e34426e85faba672fe7 (diff)
gentoo auto-resync : 15:06:2024 - 00:09:17
Diffstat (limited to 'sys-auth/libyubikey')
-rw-r--r--sys-auth/libyubikey/Manifest3
-rw-r--r--sys-auth/libyubikey/libyubikey-1.13-r1.ebuild26
-rw-r--r--sys-auth/libyubikey/libyubikey-1.13.ebuild9
3 files changed, 36 insertions, 2 deletions
diff --git a/sys-auth/libyubikey/Manifest b/sys-auth/libyubikey/Manifest
index f521e7869f56..810408015224 100644
--- a/sys-auth/libyubikey/Manifest
+++ b/sys-auth/libyubikey/Manifest
@@ -1,3 +1,4 @@
DIST libyubikey-1.13.tar.gz 347337 BLAKE2B 99bbcc16115d913ffd548625f3366405879b0537c4dbcb9f6cebc406a057de642ae621d5793f1828056bfac266eb56b9a409cde44eb26753f955c9da6bcf8c0e SHA512 28f45cb9817c30a70d168ae507d3f8014051058d730eed92b31d92e96784138dea291bda4275511c5f92a6427cb4249d76c802b8abb867cec50e62fb770950f2
-EBUILD libyubikey-1.13.ebuild 475 BLAKE2B ad2a4639abde0b006e7c75823bd6c0ff2570def43ae3960ad19591bb3208a2169f607e01b79ebea757f48ad86ba1e042c477aa6c09d9e5b17f6024930005e369 SHA512 63aec104623ccc6e654863d1cde8a09fa3368942c834a0c45fab13f2f8ab96da2e92688c0d8ec8ae049dd61d1ea143d7e1a71ca97b620f11a6af6cf34dbfa658
+EBUILD libyubikey-1.13-r1.ebuild 490 BLAKE2B 0f3b3fa9543ae1997e3ae7a9251cdd2f0baea062750c4750db40ba9316a2b17f974cb323c10de0c55972c5882083dc991cedf96a80851419667f5cfa26e5936c SHA512 f6de747b19c139285a6f30f092f9675cd5d2eea0e47b6066b1308636e4bb90bec8bbc4fb07cd3b8156c4f6f0577d45ad4c5fbbd16e7737d887537b04df53cfb3
+EBUILD libyubikey-1.13.ebuild 533 BLAKE2B 76822633450019903c2dda3c4bc5571547b245f2a702c5174a9c00a39d5f5a535c1aa181a6535fff95d955e58fe60dab70cef7c7377e57cc2ddb49b9d45ff439 SHA512 703d5c8facc83d6d13f74aed92fb860658a120c25a05a2275d37f36a38d209c163d165ee60a86f911a05518c6bff18363af14b8e28942a5b39a0878ee2887fab
MISC metadata.xml 379 BLAKE2B 53f88bb5545b975d9b065f302ac1f03d4ff8b1aee8b9c492e166847b2bb57a2105ce37adabd6317c3d0bed420236123ced9de5c1f29ae369525955fdf29d4f59 SHA512 54ccbf977aeb24ad1864a54ae368e3324d477c21fe8c008f8a6ed588bce9aa6a5ecf60015865fe27a7a066aad83921ac550936bf5bbf66a0753c80029129317d
diff --git a/sys-auth/libyubikey/libyubikey-1.13-r1.ebuild b/sys-auth/libyubikey/libyubikey-1.13-r1.ebuild
new file mode 100644
index 000000000000..b2ecb6ea9e35
--- /dev/null
+++ b/sys-auth/libyubikey/libyubikey-1.13-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Yubico C low-level library"
+HOMEPAGE="https://github.com/Yubico/yubico-c"
+SRC_URI="http://opensource.yubico.com/yubico-c/releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sys-auth/libyubikey/libyubikey-1.13.ebuild b/sys-auth/libyubikey/libyubikey-1.13.ebuild
index ca3ecbd23b6f..e6714c24923b 100644
--- a/sys-auth/libyubikey/libyubikey-1.13.ebuild
+++ b/sys-auth/libyubikey/libyubikey-1.13.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Yubico C low-level library"
HOMEPAGE="https://github.com/Yubico/yubico-c"
SRC_URI="http://opensource.yubico.com/yubico-c/releases/${P}.tar.gz"
@@ -11,6 +13,11 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf --disable-static
}